CVE-2026-87022 Apache Tomcat: WebSocket message smuggling with per-message-deflate
Attackers can smuggle WebSocket messages via per-message-deflate, potentially bypassing security controls or corrupting data in Apache Tomcat.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-87022?
CVE-2026-87022 is a high-severity vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper handling of length parameter inconsistency vulnerability in Apache Tomcat allows WebSocket message smuggling when per-message-deflate is used.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121.
The following versions were EOS at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.56 through 7.0.109. Other unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.1.22, which fix the issue.
Weakness: CWE-130
Which versions are affected by CVE-2026-87022?
1 open source package ship an affected version, including tomcat.
| Package | Affected | Fixed in |
|---|---|---|
tomcat Bitnami | From 7.0.56 | 9.0.45, 10.1.60, 11.0.26, 9.0.122 |
How do I fix CVE-2026-87022?
Upgrade tomcat to a fixed version for your release line: 9.0.45, 10.1.60, 11.0.26 or 9.0.122.
Is CVE-2026-87022 being exploited?
There is no known exploitation of CVE-2026-87022 in the wild and no public exploit code.
Sources
Also known as BIT-tomcat-2026-87022, DEBIAN-CVE-2026-87022, GHSA-xwrc-v28h-528j, MINI-6849-cj29-5wxj, MINI-mwj2-2xxp-jpqj, MINI-qjmj-cgq2-gfrc and 1 more.