CVE-2026-87029 undici vulnerable to Denial of Service via unhandled exception in the decompress interceptor

Medium 5.9 Published Updated

A malicious server can crash Node.js applications using undici by triggering an unhandled exception in the decompress interceptor when combined with size-limiting handlers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-87029?

CVE-2026-87029 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

undici is an HTTP client library for Node.js. In versions 7.15.0 through 7.30.0 and 8.0.0 through 8.12.1, its decompress interceptor forwards decompressed response data to the downstream handler from zlib stream event callbacks without catching exceptions those callbacks may throw, and while undici's engine converts a synchronous throw from a downstream handler into a per-request failure, that protection is absent when the throw happens asynchronously from a zlib callback. As a result, a downstream handler that throws by design, such as the built-in dump interceptor which throws when a response exceeds its configured maximum size, escapes as an uncaught exception that terminates the Node.js process. A malicious or compromised HTTP server can crash any client that composes the decompress interceptor with such a handler by returning a small compressed body that decompresses to more than the configured limit, so only the decompressed size matters and the bytes on the wire stay tiny. The issue is fixed in undici 7.30.1 and 8.12.2, and users should upgrade to one of those versions or later. As a workaround, avoid composing the decompress interceptor with a response handler that throws during response processing until upgrading.

Weakness: CWE-248

Which versions are affected by CVE-2026-87029?

4 open source packages ship an affected version, including undici. It affects 1 product.

PackageAffectedFixed in
undici npmFrom 7.15.07.30.1
undici npmFrom 7.15.07.30.1
undici npmFrom 8.0.08.12.2
undici npmFrom 8.0.08.12.2

Products include Nodejs Undici.

How do I fix CVE-2026-87029?

Upgrade undici to a fixed version for your release line: 7.30.1 or 8.12.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-87029 being exploited?

There is no known exploitation of CVE-2026-87029 in the wild and no public exploit code.

All Nodejs Undici vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-87029, ECHO-341d-0f3a-c605, GHSA-55wc-3pg8-jfw6, UBUNTU-CVE-2026-87029.

Is CVE-2026-87029 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free