# CVE-2026-87029: undici vulnerable to Denial of Service via unhandled exception in the decompress interceptor

> A malicious server can crash Node.js applications using undici by triggering an unhandled exception in the decompress interceptor when combined with size-limiting handlers.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-87029, ECHO-341d-0f3a-c605, GHSA-55wc-3pg8-jfw6, UBUNTU-CVE-2026-87029

## What is CVE-2026-87029?

CVE-2026-87029 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici is an HTTP client library for Node.js. In versions 7.15.0 through 7.30.0 and 8.0.0 through 8.12.1, its decompress interceptor forwards decompressed response data to the downstream handler from zlib stream event callbacks without catching exceptions those callbacks may throw, and while undici's engine converts a synchronous throw from a downstream handler into a per-request failure, that protection is absent when the throw happens asynchronously from a zlib callback. As a result, a downstream handler that throws by design, such as the built-in dump interceptor which throws when a response exceeds its configured maximum size, escapes as an uncaught exception that terminates the Node.js process. A malicious or compromised HTTP server can crash any client that composes the decompress interceptor with such a handler by returning a small compressed body that decompresses to more than the configured limit, so only the decompressed size matters and the bytes on the wire stay tiny. The issue is fixed in undici 7.30.1 and 8.12.2, and users should upgrade to one of those versions or later. As a workaround, avoid composing the decompress interceptor with a response handler that throws during response processing until upgrading.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-87029?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.15.0 | 7.30.1 |
| `undici` | npm | From 7.15.0 | 7.30.1 |
| `undici` | npm | From 8.0.0 | 8.12.2 |
| `undici` | npm | From 8.0.0 | 8.12.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-87029?

Upgrade undici to a fixed version for your release line: 7.30.1 or 8.12.2.

## Is CVE-2026-87029 being exploited?

There is no known exploitation of CVE-2026-87029 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87029 and fix it if it is affected.

What it is: CVE-2026-87029 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-87029 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.15.0; fixed in 7.30.1
- undici (npm): affected from 7.15.0; fixed in 7.30.1
- undici (npm): affected from 8.0.0; fixed in 8.12.2
- undici (npm): affected from 8.0.0; fixed in 8.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87029/ (Markdown: https://insights.sbomify.com/CVE-2026-87029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87029
- OSV: https://osv.dev/vulnerability/CVE-2026-87029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87029/
Summaries are generated and may contain mistakes; the official description above is the record.
