# CVE-2026-87090: Consul vulnerable to an authorization bypass in the catalog node-write path

> Authenticated attackers can bypass authorization to delete other nodes' catalog registrations and take over their identities in Consul.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2026
- **Updated:** 10 Sep 2026
- **Also known as:** BIT-consul-2026-87090, GHSA-mjp7-4wvg-9f57, MINI-vh9w-c9v6-44wm, MINI-xwvf-m439-62xc, UBUNTU-CVE-2026-87090

## What is CVE-2026-87090?

CVE-2026-87090 is a high-severity authentication bypass vulnerability in HashiCorp Consul, published on 10 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Consul and Consul Enterprise are vulnerable to an authorization bypass in the catalog node-write path that may allow an authenticated attacker to delete another node's catalog registration and take over its node identity. An attacker with a token granting node-write permission on any single node name may exploit this issue if they can obtain the node ID of a node they do not control. This vulnerability (CVE-2026-87090) is fixed in Consul 2.0.4 and Consul Enterprise 1.21.18, 1.22.12 and 2.0.4.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-87090?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 0.1.0 | 2.0.4 |

## How do I fix CVE-2026-87090?

Upgrade consul to 2.0.4 or later.

## Is CVE-2026-87090 being exploited?

There is no known exploitation of CVE-2026-87090 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87090 and fix it if it is affected.

What it is: CVE-2026-87090 is a high-severity authentication bypass vulnerability in HashiCorp Consul, published on 10 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-87090 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 0.1.0; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87090/ (Markdown: https://insights.sbomify.com/CVE-2026-87090/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87090
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87090
- OSV: https://osv.dev/vulnerability/CVE-2026-87090

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87090/
Summaries are generated and may contain mistakes; the official description above is the record.
