# CVE-2026-87107: Consul vulnerable to an authorization bypass in the catalog deregistration path

> Local ACL tokens can bypass authorization to delete peer-imported catalog objects in Consul, requiring an upgrade to patched versions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2026
- **Updated:** 10 Sep 2026
- **Also known as:** BIT-consul-2026-87107, GHSA-h73p-f2fq-8x97, MINI-4jj6-2f3h-qxrq, MINI-q8cg-jrv7-vfm2, UBUNTU-CVE-2026-87107

## What is CVE-2026-87107?

CVE-2026-87107 is a medium-severity authentication bypass vulnerability in HashiCorp Consul, published on 10 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Consul and Consul Enterprise are vulnerable to an authorization bypass in the catalog deregistration path that may allow a local ACL token to delete peer-imported catalog objects. A caller with {{service:write}} or {{node:write}} permission may exploit this issue to remove services, checks, or nodes imported from a peered cluster without holding authority over the peer origin. This vulnerability (CVE-2026-87107) is fixed in Consul 2.0.4 and Consul Enterprise 1.21.18, 1.22.12 and 2.0.4.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-87107?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 1.21.0 | 2.0.4 |

## How do I fix CVE-2026-87107?

Upgrade consul to 2.0.4 or later.

## Is CVE-2026-87107 being exploited?

There is no known exploitation of CVE-2026-87107 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87107 and fix it if it is affected.

What it is: CVE-2026-87107 is a medium-severity authentication bypass vulnerability in HashiCorp Consul, published on 10 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-87107 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 1.21.0; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87107/ (Markdown: https://insights.sbomify.com/CVE-2026-87107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87107
- OSV: https://osv.dev/vulnerability/CVE-2026-87107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87107/
Summaries are generated and may contain mistakes; the official description above is the record.
