{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-8712 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-8712 is a medium-severity server-side request forgery vulnerability in OHF-Voice wyoming, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-8712 and fix it if it is affected.\n\nWhat it is: CVE-2026-8712 is a medium-severity server-side request forgery vulnerability in OHF-Voice wyoming, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-8712 in the wild and no public exploit code.\n\nAffected product: OHF-Voice wyoming. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-8712/ (Markdown: https://insights.sbomify.com/CVE-2026-8712/index.md)","id":"CVE-2026-8712","markdown":"https://insights.sbomify.com/CVE-2026-8712/index.md","name":"CVE-2026-8712","record":{"aliases":["GHSA-hx93-cpfv-g2pw","openSUSE-SU-2026:12265-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Wyoming voice server","requires_auth":"none","summary":"Unauthenticated attackers can force outbound connections to arbitrary targets via malicious URI parameters in the Wyoming HTTP API.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Wyoming before 1.10.2 contains a server-side request forgery vulnerability that allows unauthenticated attackers with network access to force outbound connections to arbitrary targets by supplying a malicious `uri` query parameter to the HTTP API. Attackers can pass arbitrary `tcp://` or `unix://` URIs to affected endpoints including /api/info, /api/speech-to-text, and /api/text-to-speech to override the server-configured backend and redirect connections to attacker-chosen hosts.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2026-09-27","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-27T06:55:11Z","kind":"github_poc","ref":"https://github.com/rahulreddykarne/CVE-2026-8712-Wyoming","stars":0,"title":"CVE-2026-8712: Unauthenticated SSRF / Backend URI Override in Wyoming HTTP API via uri Query Parameter"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Wyoming \u003c 1.10.2 SSRF via uri Query Parameter","id":"CVE-2026-8712","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Avada (Fusion) Builder \u003c= 3.15.3 - Unauthenticated Arbitrary File Deletion via Form Entry Value","id":"CVE-2026-8713"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.10.2-1.1"],"introduced":["0"],"last_affected":[],"package":"python-wyoming","purl":"pkg:rpm/opensuse/python-wyoming\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12265-1"}],"prev":{"headline":"NGINX JavaScript vulnerability","id":"CVE-2026-8711"},"products":["wyoming"],"published":"2026-09-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-02","vendors":["OHF-Voice"]},"summary":"Unauthenticated attackers can force outbound connections to arbitrary targets via malicious URI parameters in the Wyoming HTTP API.","url":"https://insights.sbomify.com/CVE-2026-8712/"}