{"answers":{"affected":"1 open source package ship an affected version, including consul.","exploited":"There is no known exploitation of CVE-2026-8715 in the wild and no public exploit code.","fix":"Upgrade consul to 1.5.0 or later.","what":"CVE-2026-8715 is a critical path traversal vulnerability in HashiCorp Tooling, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-8715 and fix it if it is affected.\n\nWhat it is: CVE-2026-8715 is a critical path traversal vulnerability in HashiCorp Tooling, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-8715 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- consul (Bitnami): affected from 1.3.0; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-8715/ (Markdown: https://insights.sbomify.com/CVE-2026-8715/index.md)","id":"CVE-2026-8715","markdown":"https://insights.sbomify.com/CVE-2026-8715/index.md","name":"CVE-2026-8715","record":{"aliases":["BIT-consul-2026-8715","GHSA-99cp-g9q7-3p6c"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Vault Secrets Operator","requires_auth":"low_privilege","summary":"Attackers with limited Kubernetes permissions can read arbitrary files from the operator pod and exfiltrate credentials, leading to cluster privilege escalation.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"HashiCorp","cpe":[],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-552","name":"Files or Directories Accessible to External Parties"}],"description":"Vault Secrets Operator 1.3.0 up to 1.4.1 is vulnerable to an arbitrary file read and credential exfiltration issue in the AppRole authentication configuration that may allow a tenant with limited Kubernetes RBAC permissions to read files from the operator pod's filesystem and transmit their contents to a tenant-controlled endpoint, potentially leading to privilege escalation within the cluster. This vulnerability (CVE-2026-8715) is fixed in Vault Secrets Operator 1.5.0.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vault Secrets Operator vulnerable to arbitrary file read and credential exfiltration via AppRole secretIDPath","id":"CVE-2026-8715","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Use of Incorrectly-Resolved Name or Reference in GitLab","id":"CVE-2026-8716"},"packages":[{"ecosystem":"Bitnami","fixed":["1.5.0"],"introduced":["1.3.0"],"last_affected":[],"package":"consul","purl":"pkg:bitnami/consul","source":"BIT-consul-2026-8715"}],"prev":{"headline":"Denial-of-Service Vulnerability in RTSP Input Handling on TP-Link's Tapo C520WS","id":"CVE-2026-8714"},"products":["Tooling"],"published":"2026-08-13","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-28","vendors":["HashiCorp"]},"summary":"Attackers with limited Kubernetes permissions can read arbitrary files from the operator pod and exfiltrate credentials, leading to cluster privilege escalation.","url":"https://insights.sbomify.com/CVE-2026-8715/"}