# CVE-2026-8715: Vault Secrets Operator vulnerable to arbitrary file read and credential exfiltration via AppRole secretIDPath

> Attackers with limited Kubernetes permissions can read arbitrary files from the operator pod and exfiltrate credentials, leading to cluster privilege escalation.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** BIT-consul-2026-8715, GHSA-99cp-g9q7-3p6c

## What is CVE-2026-8715?

CVE-2026-8715 is a critical path traversal vulnerability in HashiCorp Tooling, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vault Secrets Operator 1.3.0 up to 1.4.1 is vulnerable to an arbitrary file read and credential exfiltration issue in the AppRole authentication configuration that may allow a tenant with limited Kubernetes RBAC permissions to read files from the operator pod's filesystem and transmit their contents to a tenant-controlled endpoint, potentially leading to privilege escalation within the cluster. This vulnerability (CVE-2026-8715) is fixed in Vault Secrets Operator 1.5.0.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2026-8715?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 1.3.0 | 1.5.0 |

## How do I fix CVE-2026-8715?

Upgrade consul to 1.5.0 or later.

## Is CVE-2026-8715 being exploited?

There is no known exploitation of CVE-2026-8715 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8715 and fix it if it is affected.

What it is: CVE-2026-8715 is a critical path traversal vulnerability in HashiCorp Tooling, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-8715 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 1.3.0; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8715/ (Markdown: https://insights.sbomify.com/CVE-2026-8715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8715
- OSV: https://osv.dev/vulnerability/CVE-2026-8715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8715/
Summaries are generated and may contain mistakes; the official description above is the record.
