# CVE-2026-8754: AstrBotDevs AstrBot File Upload chat.py post_file path traversal

> Remote attackers can exploit a path traversal vulnerability in the file upload handler to read or modify arbitrary files on the server.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2026
- **Updated:** 18 May 2026
- **Also known as:** GHSA-f63h-wc26-pmvc, PYSEC-2026-2380

## What is CVE-2026-8754?

CVE-2026-8754 is a medium-severity path traversal vulnerability in AstrBotDevs AstrBot, published on 17 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was detected in AstrBotDevs AstrBot up to 4.23.5. Impacted is the function post_file of the file astrbot/dashboard/routes/chat.py of the component File Upload Handler. The manipulation of the argument filename results in path traversal. It is possible to launch the attack remotely. The exploit is now public and may be used. Upgrading to version 4.23.6 is recommended to address this issue. The patch is identified as aaec41e5054569ceaa1113593a34da7568e2d211. You should upgrade the affected component.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-8754?

3 open source packages ship an affected version, including astrbot and AstrBot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `astrbot` | PyPI | All versions | 4.23.6 |
| `astrbot` | PyPI | All versions | 4.23.6 |
| `AstrBot` | PyPI | All versions | 4.23.6 |

## How do I fix CVE-2026-8754?

Upgrade astrbot to 4.23.6 or later.

## Is CVE-2026-8754 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8754 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8754 and fix it if it is affected.

What it is: CVE-2026-8754 is a medium-severity path traversal vulnerability in AstrBotDevs AstrBot, published on 17 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8754 exists.

Affected packages and fixed versions:
- astrbot (PyPI): affected all versions; fixed in 4.23.6
- astrbot (PyPI): affected all versions; fixed in 4.23.6
- AstrBot (PyPI): affected all versions; fixed in 4.23.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8754/ (Markdown: https://insights.sbomify.com/CVE-2026-8754/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8754
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8754
- OSV: https://osv.dev/vulnerability/CVE-2026-8754

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8754/
Summaries are generated and may contain mistakes; the official description above is the record.
