# CVE-2026-87689: Metasploit Framework Web Service REST API Missing Authentication on Credential Endpoints

> Attackers can read, modify, or delete stored credentials without authentication via unsecured REST API endpoints in Metasploit Framework.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-4r4h-q2gr-cvcv

## What is CVE-2026-87689?

CVE-2026-87689 is a critical missing authorization vulnerability in Rapid7 Metasploit Framework, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Metasploit Framework Web Service REST API (msf-ws) exposes the credential store through Msf::WebServices::CredentialServlet. Every mutating and read route in this servlet calls warden.authenticate! before processing a request, except the update_credential (PUT) and delete_credentials (DELETE) handlers for /api/v1/credentials, which omit the authentication call entirely. Because these handlers call directly into lib/msf/core/db_manager/cred.rb, which performs no authorization check of its own, any client able to reach the web service on its default 0.0.0.0:8080 listener can read, modify, or permanently delete every stored credential record — including passwords, hashes, and private keys stored for a shared team engagement — without presenting any authentication. All published versions of Metasploit Framework through 6.5.4 are affected. The issue is fixed in 6.5.5 by adding warden.authenticate! as the first statement in both handlers, matching the pattern used by every other route in the API.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-87689?


## How do I fix CVE-2026-87689?

No fix has been published for CVE-2026-87689 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-87689 being exploited?

There is no known exploitation of CVE-2026-87689 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87689 and fix it if it is affected.

What it is: CVE-2026-87689 is a critical missing authorization vulnerability in Rapid7 Metasploit Framework, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-87689 in the wild and no public exploit code.

Affected product: Rapid7 Metasploit Framework. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87689/ (Markdown: https://insights.sbomify.com/CVE-2026-87689/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87689
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87689
- OSV: https://osv.dev/vulnerability/CVE-2026-87689

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87689/
Summaries are generated and may contain mistakes; the official description above is the record.
