# CVE-2026-8769: vercel ai provider-utils response-handler.ts createJsonErrorResponseHandler resource consumption

> Remote attackers can cause resource consumption and denial of service in the Vercel AI SDK via the response handler functions.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2026
- **Updated:** 18 May 2026
- **Also known as:** CLEANSTART-2026-ST69641, CLSA-2026-1792161536, CLSA-2026-1793270505, CLSA-2026-1793271692, CLSA-2026-1793272798, CLSA-2026-1793276296, ECHO-183e-2b87-4034, GHSA-866g-f22w-33x8, MINI-2p6w-v23c-vhj2, MINI-3r49-77fj-4xcp, MINI-6x69-p8vw-qj7x, MINI-8gjv-rvp2-qf27, MINI-c8p8-rg85-rc3f, MINI-h53j-rr6g-2qhq, MINI-h7g3-497m-qghq, MINI-q3p8-xrjv-wj7q, MINI-qj9r-56w6-x67p, MINI-qpmr-f63w-qwh2, MINI-vjr7-v5fr-v543, MINI-vx69-3wqp-8x95

## What is CVE-2026-8769?

CVE-2026-8769 is a medium-severity denial of service vulnerability in vercel ai, published on 17 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was determined in vercel ai up to 3.0.97. The impacted element is the function createJsonResponseHandler/createJsonErrorResponseHandler of the file packages/provider-utils/src/response-handler.ts of the component provider-utils. This manipulation causes resource consumption. The attack may be initiated remotely. The exploit has been publicly disclosed and may be utilized. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-404 (Improper Resource Shutdown or Release), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-8769?

6 open source packages ship an affected version, including @ai-sdk/provider-utils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@ai-sdk/provider-utils` | npm | All versions | 3.0.28 |
| `@ai-sdk/provider-utils` | npm | All versions | 3.0.28 |
| `@ai-sdk/provider-utils` | npm | From 4.0.0-beta.10 | 4.0.33 |
| `@ai-sdk/provider-utils` | npm | From 4.0.0-beta.10 | 4.0.33 |
| `@ai-sdk/provider-utils` | npm | From 5.0.0-beta.0 | 5.0.1 |
| `@ai-sdk/provider-utils` | npm | From 5.0.0-beta.0 | 5.0.1 |

Products: Vercel Ai.

## How do I fix CVE-2026-8769?

Upgrade @ai-sdk/provider-utils to a fixed version for your release line: 3.0.28, 4.0.33 or 5.0.1.

## Is CVE-2026-8769 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8769 exists.

## Other vulnerabilities in vercel ai

- [CVE-2026-8768](https://insights.sbomify.com/CVE-2026-8768/): vercel ai provider-utils download-blob.ts validateDownloadUrl server-side request forgery (medium 6.9)
- [CVE-2025-48985](https://insights.sbomify.com/CVE-2025-48985/): Vercel’s AI SDK's filetype whitelists can be bypassed when uploading files (low 3.7)
- [CVE-2026-8767](https://insights.sbomify.com/CVE-2026-8767/): vercel ai PR Branch Name Interpolation prettier-on-automerge.yml run os command injection (low 2.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8769 and fix it if it is affected.

What it is: CVE-2026-8769 is a medium-severity denial of service vulnerability in vercel ai, published on 17 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8769 exists.

Affected packages and fixed versions:
- @ai-sdk/provider-utils (npm): affected all versions; fixed in 3.0.28
- @ai-sdk/provider-utils (npm): affected all versions; fixed in 3.0.28
- @ai-sdk/provider-utils (npm): affected from 4.0.0-beta.10; fixed in 4.0.33
- @ai-sdk/provider-utils (npm): affected from 4.0.0-beta.10; fixed in 4.0.33
- @ai-sdk/provider-utils (npm): affected from 5.0.0-beta.0; fixed in 5.0.1
- @ai-sdk/provider-utils (npm): affected from 5.0.0-beta.0; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8769/ (Markdown: https://insights.sbomify.com/CVE-2026-8769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8769
- OSV: https://osv.dev/vulnerability/CVE-2026-8769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8769/
Summaries are generated and may contain mistakes; the official description above is the record.
