# CVE-2026-87723: Untrusted Search Path (PATH Hijacking) in fuse-archive

> Attackers can hijack execution paths to run arbitrary code by manipulating the PATH environment variable in fuse-archive.

- **Severity:** Medium 5.4 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-q4qj-wcfm-8x96

## What is CVE-2026-87723?

CVE-2026-87723 is a medium-severity command injection vulnerability in Google fuse-archive, published on 28 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Google fuse-archive versions prior to 1.24, an attacker who can prepend a directory to PATH or write a malicious binary to an attacker-controlled or writable directory appearing in PATH can hijack the execution pathway. This allows the attacker to execute arbitrary local code under the security context of the user running the fuse-archive process. The issue was partially mitigated in version 1.22 and fully resolved in 1.24 via refined selective PATH filtering.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2026-87723?


## How do I fix CVE-2026-87723?

No fix has been published for CVE-2026-87723 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-87723 being exploited?

There is no known exploitation of CVE-2026-87723 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87723 and fix it if it is affected.

What it is: CVE-2026-87723 is a medium-severity command injection vulnerability in Google fuse-archive, published on 28 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-87723 in the wild and no public exploit code.

Affected product: Google fuse-archive. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87723/ (Markdown: https://insights.sbomify.com/CVE-2026-87723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87723
- OSV: https://osv.dev/vulnerability/CVE-2026-87723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87723/
Summaries are generated and may contain mistakes; the official description above is the record.
