{"answers":{"affected":"2 open source packages ship an affected version, including compression.","exploited":"There is no known exploitation of CVE-2026-87776 in the wild and no public exploit code.","fix":"Upgrade compression to 1.8.2 or later.","what":"CVE-2026-87776 is a high-severity denial of service vulnerability in compression, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-87776 and fix it if it is affected.\n\nWhat it is: CVE-2026-87776 is a high-severity denial of service vulnerability in compression, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-87776 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- compression (npm): affected all versions; fixed in 1.8.2\n- compression (npm): affected all versions; fixed in 1.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-87776/ (Markdown: https://insights.sbomify.com/CVE-2026-87776/index.md)","id":"CVE-2026-87776","markdown":"https://insights.sbomify.com/CVE-2026-87776/index.md","name":"CVE-2026-87776","record":{"aliases":["AZL-101778","CLEANSTART-2026-IQ33916","CLEANSTART-2026-WT34864","CLSA-2026-1791278863","CLSA-2026-1792473493","CLSA-2026-1792473778","CLSA-2026-1792489791","CLSA-2026-1792490254","DEBIAN-CVE-2026-87776","ECHO-abd4-2c76-3d12","GHSA-vc2v-76pw-4v95","MINI-2232-g2fg-vw22","MINI-2924-3363-jv5v","MINI-29v5-67qv-45f3","MINI-3wcf-hxfq-9cc7","MINI-gvvc-j52w-ccf8","MINI-hf27-vjmr-3phj","MINI-jq39-c438-hh8w","MINI-mcr7-hhqx-6pxq","MINI-mh6j-rw82-2cjf","MINI-v6xq-wq69-43vg","MINI-w77f-6226-q26r","ROOT-APP-NPM-CVE-2026-87776","UBUNTU-CVE-2026-87776"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js compression middleware","requires_auth":"none","summary":"A remote attacker can crash the server by repeatedly aborting compressed connections, causing a memory leak in the compression middleware.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-459","name":"Incomplete Cleanup"},{"id":"CWE-401","name":"Missing Release of Memory after Effective Lifetime"}],"description":"compression is a Node.js and Express compression middleware. In versions before 1.8.2, when a client aborts the connection while a compressed response is still being sent, the zlib stream created to compress that response is never destroyed, so each aborted compressed response leaks its native zlib memory. A remote unauthenticated attacker can repeatedly open requests and disconnect early, exhausting the available memory and crashing the server. All applications using compression are affected. The issue is fixed in compression 1.8.2, and users should upgrade to 1.8.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"compression vulnerable to Denial of Service via memory leak on premature response close","id":"CVE-2026-87776","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Hostinger Reach 1.0.6 - 1.8.2 - Contributor+ Stored XSS via formId Elementor Widget Attribute","id":"CVE-2026-87777"},"packages":[{"ecosystem":"npm","fixed":["1.8.2"],"introduced":["0"],"last_affected":[],"package":"compression","purl":null,"source":"GHSA-vc2v-76pw-4v95"},{"ecosystem":"npm","fixed":["1.8.2"],"introduced":["0"],"last_affected":[],"package":"compression","purl":"pkg:npm/compression","source":"GHSA-vc2v-76pw-4v95"}],"prev":{"headline":"Tz Weekly Radio Schedule \u003c= 1.8.1 - Unauthenticated SQLi via tzwrs_update_cell","id":"CVE-2026-87775"},"products":["compression"],"published":"2026-09-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-11","vendors":["compression"]},"summary":"A remote attacker can crash the server by repeatedly aborting compressed connections, causing a memory leak in the compression middleware.","url":"https://insights.sbomify.com/CVE-2026-87776/"}