CVE-2026-87785 Apache Syncope: JWT subject spoofing

Critical 9.1 Published Updated

Attackers can spoof user privileges and bypass authentication if internal JWT settings are disclosed, requiring an upgrade to secure Apache Syncope.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-87785?

CVE-2026-87785 is a critical authentication bypass vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Authentication bypass by spoofing vulnerability in Apache Syncope.

When the configured JWKS settings for internal JWT authentication are disclosed (at least protocol and key), an attacker can spoof another user's privileges after completing a successful authentication and obtaining a valid JWT.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2.

Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Weakness: CWE-290

Which versions are affected by CVE-2026-87785?

How do I fix CVE-2026-87785?

No fix has been published for CVE-2026-87785 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-87785 being exploited?

There is no known exploitation of CVE-2026-87785 in the wild and no public exploit code.

Sources

Also known as GHSA-v8g7-44pf-w6m4.

Is CVE-2026-87785 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free