# CVE-2026-8779: omec-project amf handler.go NGSetupRequest memory corruption

> Remote attackers can trigger memory corruption in the AMF NGSetupRequest handler, potentially leading to code execution or service disruption.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 May 2026
- **Updated:** 18 May 2026
- **Also known as:** GHSA-fxvj-wqv2-xgcq, GO-2026-5386

## What is CVE-2026-8779?

CVE-2026-8779 is a medium-severity memory corruption vulnerability in omec-project amf, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was determined in omec-project amf up to 2.1.3-dev. Impacted is the function NGSetupRequest of the file ngap/handler.go. Executing a manipulation of the argument InformationElement can lead to memory corruption. The attack can be launched remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.2.0 is recommended to address this issue. The affected component should be upgraded. The same pull request fixes multiple security issues.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-8779?

3 open source packages ship an affected version, including github.com/omec-project/amf.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/omec-project/amf` | Go | All versions | None |
| `github.com/omec-project/amf` | Go | All versions | 2.2.0 |
| `github.com/omec-project/amf` | Go | All versions | 2.2.0 |

## How do I fix CVE-2026-8779?

Upgrade github.com/omec-project/amf to 2.2.0 or later.

## Is CVE-2026-8779 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8779 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8779 and fix it if it is affected.

What it is: CVE-2026-8779 is a medium-severity memory corruption vulnerability in omec-project amf, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8779 exists.

Affected packages and fixed versions:
- github.com/omec-project/amf (Go): affected all versions; no fix listed
- github.com/omec-project/amf (Go): affected all versions; fixed in 2.2.0
- github.com/omec-project/amf (Go): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8779/ (Markdown: https://insights.sbomify.com/CVE-2026-8779/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8779
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8779
- OSV: https://osv.dev/vulnerability/CVE-2026-8779

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8779/
Summaries are generated and may contain mistakes; the official description above is the record.
