# CVE-2026-87798: LXD client recursive file pull allows directory escape via malicious VM agent

> A malicious VM agent can exploit improper link resolution in LXD client file pulls to write files to arbitrary host paths, enabling privilege escalation.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-87798, GHSA-mr8v-hx34-hfvf, UBUNTU-CVE-2026-87798

## What is CVE-2026-87798?

CVE-2026-87798 is a medium-severity path traversal vulnerability in Canonical LXD, published on 28 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Improper link resolution in the recursive file pull feature of the LXD CLI client in Canonical LXD versions 4.0.2 up to 6.9 (fixed in 4.0.14, 5.0.10 and 5.21.8) on Linux allows an attacker with root access inside a virtual machine to write attacker-controlled files or directory trees to arbitrary paths on the client host, with the operator's privileges. The attacker does this by using a modified lxd-agent that returns inconsistent SFTP directory listings and Lstat results.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-87798?


## How do I fix CVE-2026-87798?

No fix has been published for CVE-2026-87798 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-87798 being exploited?

There is no known exploitation of CVE-2026-87798 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87798 and fix it if it is affected.

What it is: CVE-2026-87798 is a medium-severity path traversal vulnerability in Canonical LXD, published on 28 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-87798 in the wild and no public exploit code.

Affected product: Canonical LXD. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87798/ (Markdown: https://insights.sbomify.com/CVE-2026-87798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87798
- OSV: https://osv.dev/vulnerability/CVE-2026-87798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87798/
Summaries are generated and may contain mistakes; the official description above is the record.
