# CVE-2026-87817: GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation

> Attackers can execute arbitrary code by impersonating the git directory and placing malicious hooks, affecting users of the GitPython library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-87817, ECHO-da18-07c8-f77a, GHSA-239g-whfq-7xj9, MINI-36cp-prvh-9228, MINI-78gr-h522-rmv9, MINI-fvj2-g7hw-46q6, MINI-wjwx-3r6h-8f68, PYSEC-2026-3982, UBUNTU-CVE-2026-87817

## What is CVE-2026-87817?

CVE-2026-87817 is a high-severity code injection vulnerability in gitpython-developers GitPython, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

GitPython before 3.1.60 fails to properly validate the git directory location, allowing attackers to impersonate the git directory using tracked files like gitdir, commondir, and HEAD. Attackers can execute arbitrary code by placing a malicious pre-commit hook in the tracked hooks directory that executes when a victim calls index.commit() on a cloned or opened repository.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-87817?

3 open source packages ship an affected version, including gitpython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.60 |
| `gitpython` | PyPI | All versions | 3.1.60 |
| `gitpython` | PyPI | All versions | 3.1.60 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-87817?

Upgrade gitpython to 3.1.60 or later.

## Is CVE-2026-87817 being exploited?

There is no known exploitation of CVE-2026-87817 in the wild and no public exploit code.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87819](https://insights.sbomify.com/CVE-2026-87819/): GitPython before 3.1.60 Denial of Service via ReDoS (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87817 and fix it if it is affected.

What it is: CVE-2026-87817 is a high-severity code injection vulnerability in gitpython-developers GitPython, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-87817 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.60
- gitpython (PyPI): affected all versions; fixed in 3.1.60
- gitpython (PyPI): affected all versions; fixed in 3.1.60

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87817/ (Markdown: https://insights.sbomify.com/CVE-2026-87817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87817
- OSV: https://osv.dev/vulnerability/CVE-2026-87817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87817/
Summaries are generated and may contain mistakes; the official description above is the record.
