# CVE-2026-87902: WordPress Core Remote File Inclusion

> Unauthenticated attackers can include arbitrary local PHP files via page template resolution, potentially leading to remote code execution under specific server and theme conditions.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 25 Sep 2026 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 26 Sep 2026
- **Also known as:** BIT-wordpress-2026-87902, BIT-wordpress-multisite-2026-87902, DEBIAN-CVE-2026-87902, MINI-469p-w96q-xx8p, MINI-h4qc-wjw9-5pwc, UBUNTU-CVE-2026-87902

## What is CVE-2026-87902?

CVE-2026-87902 is a high-severity vulnerability in Wordpress Wordpress, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An unauthenticated attacker can make `get_page_template()` page-template resolution include a chosen readable local `.php` file outside the active theme directories. If relevant pre-conditions for both the server and the active theme are met, this can lead to RCE.

Weakness: CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program)

## Which versions are affected by CVE-2026-87902?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 7.1.2 |
| `wordpress-multisite` | Bitnami | All versions | 7.1.2 |

Products: Wordpress Wordpress.

## How do I fix CVE-2026-87902?

Upgrade wordpress to 7.1.2 or later. US federal agencies must fix it by 28 Sep 2026.

## Is CVE-2026-87902 being exploited?

Yes. Attackers have exploited CVE-2026-87902 in the wild since at least 25 Sep 2026.

Public exploit code:

- PoC for CVE-2026-87902 — unauthenticated path traversal in WordPress page-template resolution (local PHP inclusion, conditional RCE) with a pinned vulnerable lab (github_poc): https://github.com/ressl/cve-2026-87902-poc
- CVE-2026-87902 - WordPress - WordPress Core - Critical 9.2 - Unauthenticated Local File Inclusion (conditional RCE) (github_poc): https://github.com/abraxas/CVE-2026-87902
- CVE-2026-87902 – WordPress Core LFI→RCE Toolkit (CVSS 9.2) - Red/Blue Team suite for WordPress 4.7–7.1.1. | 2 tools: Full Exploit (LFI, PEAR RCE, admin create, webshell, reverse shell, loot, mass scan, stealth) & SafeChecker (version detect, risk audit, JSON report). Use Ethically & Authorized Enviorement, Stay Legal  <3 (github_poc): https://github.com/tc4dy/CVE-2026-87902-Toolkit
- Reproduction lab + URL-list scanner + PoC for CVE-2026-87902 / GHSA-7hp8-65ch-5whp — WordPress get_page_template() unauthenticated LFI to conditional RCE (WP 4.7.0-7.1.1, fixed 7.1.2). Authorized/defensive testing. (github_poc): https://github.com/dinosn/cve-2026-87902-wordpress-lfi-lab
- Unauthenticated RCE on Wordpress (github_poc): https://github.com/vulpecuna/CVE-2026-87902
- XWP_RCE — CVE-2026-87902 Hacker Console (github_poc): https://github.com/tonydelouvre/CVE-2026-87902

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-63030](https://insights.sbomify.com/CVE-2026-63030/): WordPress Core Interpretation Conflict (critical 9.8, exploited in the wild)
- [CVE-2026-60137](https://insights.sbomify.com/CVE-2026-60137/): WordPress Core SQL Injection (medium 5.9, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)
- [CVE-2011-3122](https://insights.sbomify.com/CVE-2011-3122/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87902 and fix it if it is affected.

What it is: CVE-2026-87902 is a high-severity vulnerability in Wordpress Wordpress, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2026-87902 in the wild since at least 25 Sep 2026.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 7.1.2
- wordpress-multisite (Bitnami): affected all versions; fixed in 7.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87902/ (Markdown: https://insights.sbomify.com/CVE-2026-87902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87902
- OSV: https://osv.dev/vulnerability/CVE-2026-87902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87902/
Summaries are generated and may contain mistakes; the official description above is the record.
