CVE-2026-87908 multiparty vulnerable to Denial of Service via unbounded part-header accumulation

High 7.5 Published Updated

An unauthenticated attacker can crash the server by sending a request with excessively large multipart headers, exhausting memory.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-87908?

CVE-2026-87908 is a high-severity denial of service vulnerability in multiparty, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

multiparty is a Node.js library for parsing multipart/form-data request bodies. In versions from 2.1.0 up to but not including 4.3.1, the parser does not bound the amount of memory used while accumulating the headers of a single multipart part. An unauthenticated attacker can send a single request whose part carries a very large volume of header bytes, forcing the parser to buffer all of them and exhausting the process memory, which crashes the server. This is a denial of service with no confidentiality or integrity impact. The issue is fixed in multiparty 4.3.1, which caps the size of the accumulated part headers. Users should upgrade to multiparty 4.3.1 or later.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2026-87908?

How do I fix CVE-2026-87908?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-87908 being exploited?

There is no known exploitation of CVE-2026-87908 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-87908, GHSA-5h46-2939-q3wh, UBUNTU-CVE-2026-87908.

Is CVE-2026-87908 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free