# CVE-2026-87995: Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin

> An authenticated user can execute scripts in a victim's browser via a port preview iframe, leading to account takeover.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2026
- **Updated:** 10 Sep 2026
- **Also known as:** GHSA-jmc6-2wr8-h3wj, PYSEC-2026-4123

## What is CVE-2026-87995?

CVE-2026-87995 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 9 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.8.11 until 0.11.1, src/lib/components/chat/FileNav/PortPreview.svelte rendered terminal port content in an iframe sandbox containing both allow-scripts and allow-same-origin. Because the terminal proxy serves that content from the Open WebUI origin, an authenticated user with access to a shared terminal server could host script on a previewed port and take over a victim's account when the victim opened the preview. This issue is fixed in version 0.11.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-1021 (Improper Restriction of Rendered UI Layers or Frames)

## Which versions are affected by CVE-2026-87995?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.8.11 | 0.11.1 |
| `open-webui` | PyPI | From 0.8.11 | 0.11.1 |
| `open-webui` | PyPI | From 0.8.11 | 0.11.1 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-87995?

Upgrade open-webui to 0.11.1 or later.

## Is CVE-2026-87995 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-87995 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-70492](https://insights.sbomify.com/CVE-2026-70492/): Open WebUI: Stored XSS via unescaped KaTeX render-error fallback in rendered messages (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87995 and fix it if it is affected.

What it is: CVE-2026-87995 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 9 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-87995 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.8.11; fixed in 0.11.1
- open-webui (PyPI): affected from 0.8.11; fixed in 0.11.1
- open-webui (PyPI): affected from 0.8.11; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87995/ (Markdown: https://insights.sbomify.com/CVE-2026-87995/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87995
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87995
- OSV: https://osv.dev/vulnerability/CVE-2026-87995

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87995/
Summaries are generated and may contain mistakes; the official description above is the record.
