# CVE-2026-88017: rclone: FTP cross-session auth-proxy backend confusion

> An attacker can hijack an active FTP session by logging in with the same username, gaining unauthorized read and write access to another user's backend storage.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Sep 2026
- **Updated:** 11 Sep 2026
- **Also known as:** BIT-rclone-2026-88017, DEBIAN-CVE-2026-88017, GHSA-c476-6w5q-jw77, GO-2026-6458, MINI-2v46-23vf-4wx9, MINI-46fr-rwqx-w43c, MINI-5292-2qrr-qxg5, MINI-72vm-fqfq-hp3f, MINI-7r66-m253-m67r, MINI-8h3j-gg34-5383, MINI-ff78-23m6-ccwc, MINI-qwpx-vx9p-w22x, ROOT-APP-GOBINARY-CVE-2026-88017

## What is CVE-2026-88017?

CVE-2026-88017 is a high-severity authentication bypass vulnerability in rclone, published on 10 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

rclone is a command-line program to sync files and directories to and from different cloud storage providers. From 1.64.0 until 1.75.1, the FTP auth-proxy driver in cmd/serve/ftp/ftp.go stores one obscured password per username in the server-wide userPass map[string]string instead of binding the credential or VFS to the authenticated session. If two accepted credentials use the same username but resolve to different proxy backends, a later CheckPasswd login overwrites userPass[user], and subsequent getVFS operations on the first session are reauthorized with the later password. The first session can then read, create, overwrite, rename, or delete objects using the second credential’s backend authority. Exploitation requires the later same-username login to occur while the first session remains open. This issue is fixed in version 1.75.1.

Weakness: CWE-488 (Exposure of Data Element to Wrong Session)

## Which versions are affected by CVE-2026-88017?

4 open source packages ship an affected version, including github.com/rclone/rclone and rclone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rclone/rclone` | Go | From 1.64.0 | 1.75.1 |
| `github.com/rclone/rclone` | Go | From 1.64.0 | 1.75.1 |
| `github.com/rclone/rclone` | Go | From 1.64.0 | 1.75.1 |
| `rclone` | Bitnami | From 1.64.0 | 1.75.1 |

Products: Rclone Rclone.

## How do I fix CVE-2026-88017?

Upgrade github.com/rclone/rclone to 1.75.1 or later.

## Is CVE-2026-88017 being exploited?

There is no known exploitation of CVE-2026-88017 in the wild and no public exploit code.

## Other vulnerabilities in rclone

- [CVE-2026-88018](https://insights.sbomify.com/CVE-2026-88018/): rclone serve s3: --auth-proxy without --auth-key authenticates nobody - full SigV4 signature bypass (critical 9.8)
- [CVE-2026-49980](https://insights.sbomify.com/CVE-2026-49980/): Rclone: Unauthenticated command execution in `rclone rcd --rc-serve` via inline remote instantiation, bypassing CVE-2026-41179 fix (critical 9.8)
- [CVE-2026-41179](https://insights.sbomify.com/CVE-2026-41179/): RClone: Unauthenticated operations/fsinfo allows attacker-controlled backend instantiation and local command execution (critical 9.2)
- [CVE-2026-41176](https://insights.sbomify.com/CVE-2026-41176/): Rclone: Unauthenticated options/set allows runtime auth bypass, leading to sensitive operations and command execution (critical 9.2)
- [CVE-2026-59733](https://insights.sbomify.com/CVE-2026-59733/): rclone `serve restic --private-repos` authorization bypass: `..` in the URL path lets an authenticated user read, overwrite and delete other users' repositories (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88017 and fix it if it is affected.

What it is: CVE-2026-88017 is a high-severity authentication bypass vulnerability in rclone, published on 10 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-88017 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rclone/rclone (Go): affected from 1.64.0; fixed in 1.75.1
- github.com/rclone/rclone (Go): affected from 1.64.0; fixed in 1.75.1
- github.com/rclone/rclone (Go): affected from 1.64.0; fixed in 1.75.1
- rclone (Bitnami): affected from 1.64.0; fixed in 1.75.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88017/ (Markdown: https://insights.sbomify.com/CVE-2026-88017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88017
- OSV: https://osv.dev/vulnerability/CVE-2026-88017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88017/
Summaries are generated and may contain mistakes; the official description above is the record.
