# CVE-2026-88021: Consul vulnerable to an authorization bypass in the Connect service mesh

> Attackers can bypass Connect service mesh authorization rules to access unauthorized destinations due to improper character escaping in generated RBAC policies.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2026
- **Updated:** 2 Oct 2026
- **Also known as:** BIT-consul-2026-88021, GHSA-9p3q-p26q-fxxc, MINI-f6wr-99pf-h2vc, MINI-hv3j-3x8j-3q96, UBUNTU-CVE-2026-88021

## What is CVE-2026-88021?

CVE-2026-88021 is a high-severity authentication bypass vulnerability in HashiCorp Consul, published on 10 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Consul and Consul Enterprise are vulnerable to an authorization bypass in the Connect service mesh that may allow a service to reach a destination it is not authorized to access. When building Envoy RBAC rules to enforce Connect intentions, Consul did not correctly escape certain characters in service names, namespaces, and partitions, causing the generated authorization rules to match more broadly than intended. This vulnerability (CVE-2026-88021) is fixed in Consul 2.0.4 and Consul Enterprise 1.21.18, 1.22.12 and 2.0.4.

Weakness: CWE-185 (Incorrect Regular Expression)

## Which versions are affected by CVE-2026-88021?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 1.9.0 | 2.0.4 |

## How do I fix CVE-2026-88021?

Upgrade consul to 2.0.4 or later.

## Is CVE-2026-88021 being exploited?

There is no known exploitation of CVE-2026-88021 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88021 and fix it if it is affected.

What it is: CVE-2026-88021 is a high-severity authentication bypass vulnerability in HashiCorp Consul, published on 10 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-88021 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 1.9.0; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88021/ (Markdown: https://insights.sbomify.com/CVE-2026-88021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88021
- OSV: https://osv.dev/vulnerability/CVE-2026-88021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88021/
Summaries are generated and may contain mistakes; the official description above is the record.
