# CVE-2026-88057: Angular: Sanitization bypass via directive host bindings on concrete host elements in @angular/core and @angular/compiler

> Attackers can execute arbitrary JavaScript in user browsers by bypassing Angular's sanitization on specific host bindings, affecting all Angular applications.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Sep 2026
- **Updated:** 11 Sep 2026
- **Also known as:** CLSA-2026-1790416421, CLSA-2026-1790431292, CLSA-2026-1790444995, CLSA-2026-1790468982, CLSA-2026-1790479328, CLSA-2026-1792161348, CLSA-2026-1792163742, CLSA-2026-1792208276, CLSA-2026-1792250344, CLSA-2026-1792281394, CLSA-2026-1792325613, CLSA-2026-1792345414, CLSA-2026-1792357501, CLSA-2026-1792366720, CLSA-2026-1792371788, CLSA-2026-1792375868, CLSA-2026-1792380177, CLSA-2026-1792382747, CLSA-2026-1792386236, DEBIAN-CVE-2026-88057, GHSA-hh8m-fm6v-7cvg, UBUNTU-CVE-2026-88057

## What is CVE-2026-88057?

CVE-2026-88057 is a medium-severity cross-site scripting vulnerability in angular, published on 10 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.28, 21.2.20, and 22.1.0, Angular's compiler and runtime in @angular/core and @angular/compiler could omit or select an incorrect sanitizer for security-sensitive directive host bindings because SecurityContext was derived from the declaring directive or component selector rather than the concrete host element. The mismatch is reachable through hostDirectives composition, inherited HostBinding declarations, createComponent with a custom hostElement or dynamic directives, SVG/MathML namespace elements, and tag-neutral selectors such as :not(...). Attacker-controlled href, src, action, xlink:href, or data values can therefore reach DOM attributes without Angular's built-in sanitizer and execute arbitrary JavaScript in the user's browser context. Applications unable to upgrade can use DomSanitizer.sanitize with SecurityContext.URL before assignment or restrict inputs to validated HTTP and HTTPS URL schemes. This issue is fixed in versions 20.3.28, 21.2.20, and 22.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-88057?

16 open source packages ship an affected version, including @angular/compiler and @angular/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/compiler` | npm | All versions to 19.2.25 | None |
| `@angular/compiler` | npm | All versions to 19.2.25 | None |
| `@angular/compiler` | npm | From 20.0.0 | 20.3.28 |
| `@angular/compiler` | npm | From 20.0.0 | 20.3.28 |
| `@angular/compiler` | npm | From 21.0.0 | 21.2.20 |
| `@angular/compiler` | npm | From 21.0.0 | 21.2.20 |
| `@angular/compiler` | npm | From 22.0.0 | 22.1.0 |
| `@angular/compiler` | npm | From 22.0.0 | 22.1.0 |
| `@angular/core` | npm | All versions to 19.2.25 | None |
| `@angular/core` | npm | All versions to 19.2.25 | None |
| `@angular/core` | npm | From 20.0.0 | 20.3.28 |
| `@angular/core` | npm | From 20.0.0 | 20.3.28 |
| `@angular/core` | npm | From 21.0.0 | 21.2.20 |
| `@angular/core` | npm | From 21.0.0 | 21.2.20 |
| `@angular/core` | npm | From 22.0.0 | 22.1.0 |
| `@angular/core` | npm | From 22.0.0 | 22.1.0 |

Products: Angular Angular.

## How do I fix CVE-2026-88057?

Upgrade @angular/compiler to a fixed version for your release line: 20.3.28, 21.2.20 or 22.1.0.

## Is CVE-2026-88057 being exploited?

There is no known exploitation of CVE-2026-88057 in the wild and no public exploit code.

## Other vulnerabilities in angular

- [CVE-2026-68945](https://insights.sbomify.com/CVE-2026-68945/): Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning (high 8.8)
- [CVE-2026-46417](https://insights.sbomify.com/CVE-2026-46417/): Angular: SSRF via Hostname Hijacking in @angular/platform-server (high 8.8)
- [CVE-2026-50168](https://insights.sbomify.com/CVE-2026-50168/): Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass (high 8.8)
- [CVE-2026-54266](https://insights.sbomify.com/CVE-2026-54266/): Angular: Weak 32-Bit Cache Key Hashing in `HttpTransferCache` Leading to Cross-Request Data Leakage and State Poisoning (high 8.8)
- [CVE-2026-41423](https://insights.sbomify.com/CVE-2026-41423/): Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88057 and fix it if it is affected.

What it is: CVE-2026-88057 is a medium-severity cross-site scripting vulnerability in angular, published on 10 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-88057 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/compiler (npm): affected all versions up to 19.2.25; no fix listed
- @angular/compiler (npm): affected all versions up to 19.2.25; no fix listed
- @angular/compiler (npm): affected from 20.0.0; fixed in 20.3.28
- @angular/compiler (npm): affected from 20.0.0; fixed in 20.3.28
- @angular/compiler (npm): affected from 21.0.0; fixed in 21.2.20
- @angular/compiler (npm): affected from 21.0.0; fixed in 21.2.20
- @angular/compiler (npm): affected from 22.0.0; fixed in 22.1.0
- @angular/compiler (npm): affected from 22.0.0; fixed in 22.1.0
- @angular/core (npm): affected all versions up to 19.2.25; no fix listed
- @angular/core (npm): affected all versions up to 19.2.25; no fix listed
- @angular/core (npm): affected from 20.0.0; fixed in 20.3.28
- @angular/core (npm): affected from 20.0.0; fixed in 20.3.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88057/ (Markdown: https://insights.sbomify.com/CVE-2026-88057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88057
- OSV: https://osv.dev/vulnerability/CVE-2026-88057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88057/
Summaries are generated and may contain mistakes; the official description above is the record.
