# CVE-2026-88065: `tts-be` application has a Broken Access Control vulnerability

> Remote attackers can bypass authorization to extract sensitive student PII and use the backend as an open proxy.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-fpfp-hr42-fvpm

## What is CVE-2026-88065?

CVE-2026-88065 is a high-severity missing authorization vulnerability in NIAEFEUP tts-be, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

`tts-be` is a backend for a timetable selector that aims to help students better choose their class schedules. Versions prior to 2.1.0 have a Broken Access Control vulnerability across several API endpoints (such as `/api/student/{id}/photo` and `/api/course_unit/{id}/exchange/metadata`). By chaining these unauthenticated endpoints, a remote attacker can use the backend as an open proxy to bypass authorization checks, allowing for the enumeration and extraction of sensitive Personally Identifiable Information (PII) from upstream university systems. The exposed data includes full names, student IDs, class schedules, and photos. This issue was fixed in version 2.1.0.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-306 (Missing Authentication for Critical Functionality), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-88065?


## How do I fix CVE-2026-88065?

No fix has been published for CVE-2026-88065 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-88065 being exploited?

There is no known exploitation of CVE-2026-88065 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88065 and fix it if it is affected.

What it is: CVE-2026-88065 is a high-severity missing authorization vulnerability in NIAEFEUP tts-be, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-88065 in the wild and no public exploit code.

Affected product: NIAEFEUP tts-be. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88065/ (Markdown: https://insights.sbomify.com/CVE-2026-88065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88065
- OSV: https://osv.dev/vulnerability/CVE-2026-88065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88065/
Summaries are generated and may contain mistakes; the official description above is the record.
