# CVE-2026-8813: ExifReader is vulnerable to denial of service via crafted ICC `mluc` tag

> A crafted image can cause memory exhaustion in the exifreader library, leading to denial of service in applications parsing untrusted images.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-h64w-w9pr-82m4

## What is CVE-2026-8813?

CVE-2026-8813 is a high-severity denial of service vulnerability in exifreader, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects versions of the package exifreader before 4.39.0. A crafted image containing an ICC mluc tag can set an attacker-controlled record count together with a zero record size. During parsing, ExifReader repeatedly processes the same record and appends entries to an array without sufficient bounds validation, causing excessive memory growth. In applications that parse attacker-supplied images, this may lead to denial of service through memory exhaustion.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-8813?

2 open source packages ship an affected version, including exifreader.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `exifreader` | npm | From 2.10.0 | 4.39.0 |
| `exifreader` | npm | From 2.10.0 | 4.39.0 |

## How do I fix CVE-2026-8813?

Upgrade exifreader to 4.39.0 or later.

## Is CVE-2026-8813 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8813 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8813 and fix it if it is affected.

What it is: CVE-2026-8813 is a high-severity denial of service vulnerability in exifreader, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8813 exists.

Affected packages and fixed versions:
- exifreader (npm): affected from 2.10.0; fixed in 4.39.0
- exifreader (npm): affected from 2.10.0; fixed in 4.39.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8813/ (Markdown: https://insights.sbomify.com/CVE-2026-8813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8813
- OSV: https://osv.dev/vulnerability/CVE-2026-8813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8813/
Summaries are generated and may contain mistakes; the official description above is the record.
