CVE-2026-8814 ExifReader is vulnerable to denial of service via unbounded decompression of image metadata

Medium 6.9 Published Updated

Attackers can cause memory exhaustion and denial of service by providing crafted PNG files with highly compressed metadata to applications using this library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-8814?

CVE-2026-8814 is a medium-severity denial of service vulnerability in exifreader, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Versions of the package exifreader before 4.39.0 are vulnerable to Improper Handling of Highly Compressed Data (Data Amplification) due to decompressing PNG zTXt metadata without enforcing a built-in maximum decompressed output size. When asynchronous parsing is enabled, a crafted PNG file containing a highly compressed zTXt chunk can cause ExifReader to materialize a disproportionately large Comment value in memory.

Weakness: CWE-409

Which versions are affected by CVE-2026-8814?

2 open source packages ship an affected version, including exifreader.

PackageAffectedFixed in
exifreader npmFrom 4.20.04.39.0
exifreader npmFrom 4.20.04.39.0

How do I fix CVE-2026-8814?

Upgrade exifreader to 4.39.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-8814 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8814 exists.

Sources

Also known as GHSA-rr89-w3h9-m66j.

Is CVE-2026-8814 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free