{"answers":{"affected":"2 open source packages ship an affected version, including exifreader.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8814 exists.","fix":"Upgrade exifreader to 4.39.0 or later.","what":"CVE-2026-8814 is a medium-severity denial of service vulnerability in exifreader, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-8814 and fix it if it is affected.\n\nWhat it is: CVE-2026-8814 is a medium-severity denial of service vulnerability in exifreader, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8814 exists.\n\nAffected packages and fixed versions:\n- exifreader (npm): affected from 4.20.0; fixed in 4.39.0\n- exifreader (npm): affected from 4.20.0; fixed in 4.39.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-8814/ (Markdown: https://insights.sbomify.com/CVE-2026-8814/index.md)","id":"CVE-2026-8814","markdown":"https://insights.sbomify.com/CVE-2026-8814/index.md","name":"CVE-2026-8814","record":{"aliases":["GHSA-rr89-w3h9-m66j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript EXIF library","requires_auth":"none","summary":"Attackers can cause memory exhaustion and denial of service by providing crafted PNG files with highly compressed metadata to applications using this library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"Versions of the package exifreader before 4.39.0 are vulnerable to Improper Handling of Highly Compressed Data (Data Amplification) due to decompressing PNG zTXt metadata without enforcing a built-in maximum decompressed output size. When asynchronous parsing is enabled, a crafted PNG file containing a highly compressed zTXt chunk can cause ExifReader to materialize a disproportionately large Comment value in memory.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ExifReader is vulnerable to denial of service via unbounded decompression of image metadata","id":"CVE-2026-8814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Playbooks run owner channel membership permission bypass","id":"CVE-2026-8821"},"packages":[{"ecosystem":"npm","fixed":["4.39.0"],"introduced":["4.20.0"],"last_affected":[],"package":"exifreader","purl":null,"source":"GHSA-rr89-w3h9-m66j"},{"ecosystem":"npm","fixed":["4.39.0"],"introduced":["4.20.0"],"last_affected":[],"package":"exifreader","purl":"pkg:npm/exifreader","source":"GHSA-rr89-w3h9-m66j"}],"prev":{"headline":"ExifReader is vulnerable to denial of service via crafted ICC `mluc` tag","id":"CVE-2026-8813"},"products":["exifreader"],"published":"2026-05-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-19","vendors":["n/a"]},"summary":"Attackers can cause memory exhaustion and denial of service by providing crafted PNG files with highly compressed metadata to applications using this library.","url":"https://insights.sbomify.com/CVE-2026-8814/"}