# CVE-2026-8814: ExifReader is vulnerable to denial of service via unbounded decompression of image metadata

> Attackers can cause memory exhaustion and denial of service by providing crafted PNG files with highly compressed metadata to applications using this library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 19 May 2026
- **Also known as:** GHSA-rr89-w3h9-m66j

## What is CVE-2026-8814?

CVE-2026-8814 is a medium-severity denial of service vulnerability in exifreader, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package exifreader before 4.39.0 are vulnerable to Improper Handling of Highly Compressed Data (Data Amplification) due to decompressing PNG zTXt metadata without enforcing a built-in maximum decompressed output size. When asynchronous parsing is enabled, a crafted PNG file containing a highly compressed zTXt chunk can cause ExifReader to materialize a disproportionately large Comment value in memory.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-8814?

2 open source packages ship an affected version, including exifreader.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `exifreader` | npm | From 4.20.0 | 4.39.0 |
| `exifreader` | npm | From 4.20.0 | 4.39.0 |

## How do I fix CVE-2026-8814?

Upgrade exifreader to 4.39.0 or later.

## Is CVE-2026-8814 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8814 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8814 and fix it if it is affected.

What it is: CVE-2026-8814 is a medium-severity denial of service vulnerability in exifreader, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8814 exists.

Affected packages and fixed versions:
- exifreader (npm): affected from 4.20.0; fixed in 4.39.0
- exifreader (npm): affected from 4.20.0; fixed in 4.39.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8814/ (Markdown: https://insights.sbomify.com/CVE-2026-8814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8814
- OSV: https://osv.dev/vulnerability/CVE-2026-8814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8814/
Summaries are generated and may contain mistakes; the official description above is the record.
