CVE-2026-8823 User Manager can demote bot accounts to guest without bot-management permission
Lower-privileged administrators can demote arbitrary bot accounts to guest status without proper bot-management permissions, potentially disrupting automated services.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-8823?
CVE-2026-8823 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 11.7.x <= 11.7.0, 10.11.x <= 10.11.17 fail to validate bot targets when demoting users to guests which allows a lower-privileged administrator to degrade arbitrary bot accounts via the standard demote-user API.. Mattermost Advisory ID: MMSA-2026-00669
Weakness: CWE-863
Which versions are affected by CVE-2026-8823?
10 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.18 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.18 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.18+incompatible, 11.7.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.7.0 | 11.7.1 |
github.com/mattermost/mattermost-server Go | From 11.7.0 | 11.7.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
4 more packages
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260518160100-9bd77d3fc4d2 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260518160100-9bd77d3fc4d2 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260518160100-9bd77d3fc4d2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-8823?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.18, 10.11.18+incompatible, 11.7.1+incompatible or 11.7.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-8823 being exploited?
There is no known exploitation of CVE-2026-8823 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-xmfh-3ccg-c9fx, GO-2026-6547.