# CVE-2026-88257: beam_mcp: nested tool argument constraints advertised but not enforced

> An attacker can bypass input validation in beam_mcp by sending nested arguments that violate advertised schemas, potentially causing unexpected behavior in host applications.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** EEF-CVE-2026-88257, GHSA-mrg2-4747-fmpw, GHSA-pgrr-g28j-jvp6

## What is CVE-2026-88257?

CVE-2026-88257 is a medium-severity vulnerability in ScriptKittyOS beam_mcp, published on 8 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Input Validation vulnerability in BeamMCP.Schema in ScriptKittyOS beam_mcp allows an MCP client to reach a tool's dispatch function with arguments that violate the input schema the server advertised. BeamMCP.Schema.validate/2 checked type, required, additionalProperties, enum and numeric bounds on the top-level arguments object only. Constraints inside nested objects and on array items (items, minItems, maxItems, minLength, maxLength, pattern, nested required, enum and additionalProperties: false) were advertised by tools/list and never checked at tools/call or prompts/get, and keywords outside the enforced subset (oneOf, anyOf, $ref) were advertised and ignored.

A host whose dispatch code relies on the schema it declared receives values the schema forbids, such as an out-of-range number or an undeclared key inside a nested object. What the host does with such a value decides the impact.

This issue affects beam_mcp: from 0.1.0 before 0.10.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-88257?

1 open source package ship an affected version, including beam_mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `beam_mcp` | Hex | From 0.1.0 | 0.10.1 |

## How do I fix CVE-2026-88257?

Upgrade beam_mcp to 0.10.1 or later.

## Is CVE-2026-88257 being exploited?

There is no known exploitation of CVE-2026-88257 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88257 and fix it if it is affected.

What it is: CVE-2026-88257 is a medium-severity vulnerability in ScriptKittyOS beam_mcp, published on 8 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-88257 in the wild and no public exploit code.

Affected packages and fixed versions:
- beam_mcp (Hex): affected from 0.1.0; fixed in 0.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88257/ (Markdown: https://insights.sbomify.com/CVE-2026-88257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88257
- OSV: https://osv.dev/vulnerability/CVE-2026-88257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88257/
Summaries are generated and may contain mistakes; the official description above is the record.
