CVE-2026-8843 Calling createIndex with certain index types can crash mongod

High 7.1 Published Updated

Attackers can crash the MongoDB server by inserting documents into collections with specific malformed index types, causing a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-8843?

CVE-2026-8843 is a high-severity denial of service vulnerability in Mongodb Mongodb, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Creating a "2dsphere_bucket" index on a non-timeseries bucket collection will succeed, but any subsequent attempt to insert a document which triggers updating that index will crash the server. A similar issue occurs when creating "queryable_encrypted_range" indices.

This issue affects MongoDB Server v7.0 versions prior to 7.0.32, v8.0 versions prior to 8.0.21 and v8.2 versions prior to 8.2.6

Weakness: CWE-617

Which versions are affected by CVE-2026-8843?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 7.0.07.0.32, 8.0.21, 8.2.6

Products include Mongodb Mongodb.

How do I fix CVE-2026-8843?

Upgrade mongodb to a fixed version for your release line: 7.0.32, 8.0.21 or 8.2.6.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-8843 being exploited?

There is no known exploitation of CVE-2026-8843 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2026-8843, GHSA-v7q4-vccc-3jxg, MINI-5v3q-pfqw-c9jg, MINI-qpm5-9hmh-f2vf, UBUNTU-CVE-2026-8843.

Is CVE-2026-8843 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free