# CVE-2026-88879: Traefik before v2.11.56 Identity Spoofing via Header Alias

> Attackers can spoof identity headers to bypass authentication and escalate privileges in backends by exploiting header canonicalization flaws in Traefik.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-cwr6-3wm2-9xhw, MINI-m3mx-vhvw-52ww, MINI-r6ff-6p33-32xr, MINI-v23m-c3ph-2j7p

## What is CVE-2026-88879?

CVE-2026-88879 is a medium-severity authentication bypass vulnerability in Traefik Traefik, published on 10 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Traefik is an HTTP reverse proxy and load balancer. In Traefik v1.x, v2.x through v2.11.55, and v3.0.0 through v3.7.11, header names are canonicalized only on dashes, so X-Auth-User, X_Auth_User and X.Auth.User are treated as three distinct headers by Traefik, while backends that derive variable names from header names (CGI, WSGI, PHP, NGINX and others) collapse them into a single variable. A client can therefore smuggle a dot-form alias of a header that Traefik manages past the middleware managing it — for example supplying X.Authenticated.User alongside the canonical X-Authenticated-User written by the ForwardAuth middleware — causing such a backend to read the client-supplied value instead of the identity Traefik asserted. In the tested configuration (PHP 8.2 built-in SAPI over an HTTP/1 backend path), Go's lexical header ordering makes the attacker-supplied value win deterministically, so a client that ForwardAuth admits as a low-privilege identity can be treated by the backend as a different user or role. Any header Traefik sets is affected, not only ForwardAuth's. This is an incomplete fix for GHSA-x677-9fxg-v5c5, which blocked only the underscore form. Fixed in v2.11.56 and v3.7.12, which add the aliasHeadersStrategy entry-point option; because it defaults to 'keep' for backwards compatibility, it must be explicitly set to 'delete' or 'reject' for the fix to take effect. Unmaintained release lines will not receive a patch.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-88879?

It affects 1 product.


Products: Traefik Traefik.

## How do I fix CVE-2026-88879?

Change a configuration setting.

## Is CVE-2026-88879 being exploited?

There is no known exploitation of CVE-2026-88879 in the wild and no public exploit code.

## Other vulnerabilities in Traefik Traefik

- [CVE-2024-45410](https://insights.sbomify.com/CVE-2024-45410/): HTTP client can remove the X-Forwarded headers in Traefik (critical 9.8)
- [CVE-2026-88877](https://insights.sbomify.com/CVE-2026-88877/): Traefik v3.7.0 Authentication Bypass via from-to-www-redirect (critical 9.3)
- [CVE-2026-85595](https://insights.sbomify.com/CVE-2026-85595/): Traefik before v2.11.55 and v3.0.0 through v3.7.10 Authentication Bypass via digestAuth (critical 9.3)
- [CVE-2026-88007](https://insights.sbomify.com/CVE-2026-88007/): Traefik HTTP/3 Backend NTLM Connection Reuse (critical 9.1)
- [CVE-2026-88009](https://insights.sbomify.com/CVE-2026-88009/): Traefik: Rootless HTTP/1 request-target routes as "/" but is forwarded verbatim, bypassing path-scoped routing, middleware guards and access logging (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88879 and fix it if it is affected.

What it is: CVE-2026-88879 is a medium-severity authentication bypass vulnerability in Traefik Traefik, published on 10 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-88879 in the wild and no public exploit code.

Affected product: Traefik Traefik. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88879/ (Markdown: https://insights.sbomify.com/CVE-2026-88879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88879
- OSV: https://osv.dev/vulnerability/CVE-2026-88879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88879/
Summaries are generated and may contain mistakes; the official description above is the record.
