# CVE-2026-88886: Renovate before 44.14.7 Command Injection via gradle-wrapper

> Attackers can execute arbitrary commands via crafted Gradle wrapper URLs in self-hosted Renovate deployments with unsafe executions enabled.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-5m6m-mfxc-qh95, GHSA-7chm-46wx-888m

## What is CVE-2026-88886?

CVE-2026-88886 is a high-severity command injection vulnerability in mend-renovate-ce, published on 10 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Renovate is a dependency update automation tool. In versions before 44.14.7 (and in Mend Renovate CE/EE distributions before 15.4.0, and the mend-renovate-enterprise-edition Helm chart before 10.4.0), the manager/gradle-wrapper module does not escape the distributionUrl value read from a repository's gradle/wrapper/gradle-wrapper.properties file before invoking the Gradle Wrapper CLI. In self-hosted deployments configured with binarySource=docker and allowedUnsafeExecutions=['gradleWrapper', ...], a repository that supplies a crafted distributionUrl (for example, appending a shell metacharacter and command) can cause arbitrary commands to be executed as the Renovate user when Renovate processes a Gradle Wrapper update. The issue is fixed in Renovate 44.14.7; as a workaround, remove 'gradleWrapper' from allowedUnsafeExecutions.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-88886?


## How do I fix CVE-2026-88886?

No fix has been published for CVE-2026-88886 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-88886 being exploited?

There is no known exploitation of CVE-2026-88886 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88886 and fix it if it is affected.

What it is: CVE-2026-88886 is a high-severity command injection vulnerability in mend-renovate-ce, published on 10 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-88886 in the wild and no public exploit code.

Affected product: mend-renovate-ce. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88886/ (Markdown: https://insights.sbomify.com/CVE-2026-88886/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88886
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88886
- OSV: https://osv.dev/vulnerability/CVE-2026-88886

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88886/
Summaries are generated and may contain mistakes; the official description above is the record.
