# CVE-2026-88901: Apache Camel: Camel-Smooks XML External Entity Processing, external entities resolved by default


- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-x4v6-22c3-2wm5

## What is CVE-2026-88901?

CVE-2026-88901 is a high-severity vulnerability in Apache Camel, published on 19 Oct 2026. 

### Official description

Improper Restriction of XML External Entity Reference vulnerability in Apache Camel.

This issue affects Apache Camel: from 4.7.0 before 4.18.5, from 4.19.0 before 4.22.1.

Improper Restriction of XML External Entity Reference in the Smooks component (camel-smooks) in Apache Camel allows an attacker who supplies the XML message body to read local files or issue requests to internal network locations via an external entity declaration in that body. This issue affects Apache Camel: from 4.7.0 before 4.18.5, from 4.19.0 before 4.22.1. The Smooks data format (.unmarshal().smooks(...)) and the Smooks component (smooks:) parse the incoming XML body with the reader Smooks resolves by default, which is the Woodstox SAX parser. That reader resolves external general and parameter entities and loads external DTDs, and camel-smooks applied none of the parser hardening that the other Camel XML components apply. A DOCTYPE with an external subset, or an external general entity, declared in the XML document is therefore resolved and expanded while the body is unmarshalled, and the resolved content is bound into the unmarshalled result and returned on InOut routes. An external sender whose XML reaches a camel-smooks data format or endpoint could therefore read files readable by the Camel process and cause the process to issue requests to hosts the document names. No non-default option is required, since resolving external entities was the default behaviour. Configurations that declare their own reader - EDI, CSV, JSON, or a custom reader - do not use the XML reader and are not affected. Users are recommended to upgrade to version 4.18.5, 4.22.1 or 4.23.0, which fixes the issue.

Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. camel-smooks now parses the XML body with a javax.xml.parsers.DocumentBuilder that does not resolve external general or parameter entities and does not load external DTDs, and hands Smooks the resulting document, matching the secure XML processing configuration used by org.apache.camel.converter.jaxp.XmlConverter and the other Camel XML components. This hardening is applied only when the Smooks configuration parses XML with its default reader, so EDI, CSV, JSON and custom-reader configurations, and the marshalling direction, are unchanged. A new allowExternalEntities option, disabled by default, restores the previous behaviour for trusted legacy configurations that rely on external entity resolution. The camel-4.14.x releases stream and earlier reached end of life before this issue was resolved and will not receive a fix, so deployments on those lines must move to a supported release. For deployments that cannot upgrade immediately, do not apply camel-smooks to XML received from untrusted senders.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2026-88901?


## How do I fix CVE-2026-88901?

No fix has been published for CVE-2026-88901 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-88901 being exploited?

There is no known exploitation of CVE-2026-88901 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-88901 — Apache Camel camel-smooks XML External Entity (XXE) processing (CWE-611, HIGH). Camel Spring Boot. (github_poc): https://github.com/oscerd/CVE-2026-88901

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88901 and fix it if it is affected.

What it is: CVE-2026-88901 is a high-severity vulnerability in Apache Camel, published on 19 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-88901 in the wild and no public exploit code.

Affected product: Apache Camel. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88901/ (Markdown: https://insights.sbomify.com/CVE-2026-88901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88901
- OSV: https://osv.dev/vulnerability/CVE-2026-88901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88901/
Summaries are generated and may contain mistakes; the official description above is the record.
