# CVE-2026-88922: Go-getter vulnerable to a privilege escalation issue in its archive decompression handling

> A crafted archive in go-getter can cause files to be extracted with elevated permissions, allowing local privilege escalation when extracted by a privileged user.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 20 Sep 2026
- **Also known as:** AZL-103254, DEBIAN-CVE-2026-88922, GHSA-34p9-pr49-jvvc, RHSA-2026:68251, RHSA-2026:68255, RHSA-2026:68259, RHSA-2026:68261, UBUNTU-CVE-2026-88922

## What is CVE-2026-88922?

CVE-2026-88922 is a medium-severity vulnerability in HashiCorp Shared library, published on 15 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

The go-getter library up to versions 1.8.8 and 2.2.3 is vulnerable to a privilege escalation issue in its archive decompression handling that may allow a crafted archive to cause extracted files to be created with elevated permission bits. Where extraction is performed by a privileged user, this may allow a local actor to obtain the privileges of the extracting process. This vulnerability (CVE-2026-88922) is fixed in go-getter 1.8.9 and 2.2.4.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2026-88922?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grype` | Red Hat:hummingbird:1 | All versions | 0:0.118.0-0.2.hum1 |
| `opentofu1.10` | Red Hat:hummingbird:1 | All versions | 0:1.10.10-0.4.hum1 |
| `opentofu1.12` | Red Hat:hummingbird:1 | All versions | 0:1.12.6-0.2.hum1 |
| `syft` | Red Hat:hummingbird:1 | All versions | 0:1.51.1-0.2.hum1 |

## How do I fix CVE-2026-88922?

Upgrade to a fixed version.

## Is CVE-2026-88922 being exploited?

There is no known exploitation of CVE-2026-88922 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88922 and fix it if it is affected.

What it is: CVE-2026-88922 is a medium-severity vulnerability in HashiCorp Shared library, published on 15 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-88922 in the wild and no public exploit code.

Affected product: HashiCorp Shared library. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88922/ (Markdown: https://insights.sbomify.com/CVE-2026-88922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88922
- OSV: https://osv.dev/vulnerability/CVE-2026-88922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88922/
Summaries are generated and may contain mistakes; the official description above is the record.
