{"answers":{"affected":"2 open source packages ship an affected version, including multer.","exploited":"There is no known exploitation of CVE-2026-88932 in the wild and no public exploit code.","fix":"Upgrade multer to 2.4.0 or later.","what":"CVE-2026-88932 is a medium-severity denial of service vulnerability in multer, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-88932 and fix it if it is affected.\n\nWhat it is: CVE-2026-88932 is a medium-severity denial of service vulnerability in multer, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-88932 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- multer (npm): affected from 2.2.0; fixed in 2.4.0\n- multer (npm): affected from 2.2.0; fixed in 2.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-88932/ (Markdown: https://insights.sbomify.com/CVE-2026-88932/index.md)","id":"CVE-2026-88932","markdown":"https://insights.sbomify.com/CVE-2026-88932/index.md","name":"CVE-2026-88932","record":{"aliases":["CLSA-2026-1790673440","ECHO-6a35-9e34-bdfe","GHSA-3pph-fpjx-jg34","MINI-4pg4-4qqm-vf96","MINI-76h6-x6cc-7qhj","MINI-cgj7-7vv5-fc67","ROOT-APP-NPM-CVE-2026-88932"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js upload middleware","requires_auth":"none","summary":"Remote attackers can exhaust disk space by repeatedly aborting uploads, causing denial of service in applications using this Node.js library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-459","name":"Incomplete Cleanup"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"multer is a Node.js middleware for handling multipart/form-data uploads. In versions 2.2.0 through 2.3.0, when a request using disk storage is aborted mid-upload, file writes that complete after multer has already run its abort cleanup are not removed, so each aborted upload can leave an orphaned file on disk. A remote unauthenticated attacker can repeatedly start and abort uploads to accumulate orphaned files and exhaust disk space, causing a denial of service. The issue is fixed in multer 2.4.0, and users should upgrade to 2.4.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"multer vulnerable to Denial of Service via orphaned disk writes on aborted uploads","id":"CVE-2026-88932","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"knowns through 0.33.0 Path Traversal via Template Engine","id":"CVE-2026-88937"},"packages":[{"ecosystem":"npm","fixed":["2.4.0"],"introduced":["2.2.0"],"last_affected":[],"package":"multer","purl":null,"source":"GHSA-3pph-fpjx-jg34"},{"ecosystem":"npm","fixed":["2.4.0"],"introduced":["2.2.0"],"last_affected":[],"package":"multer","purl":"pkg:npm/multer","source":"GHSA-3pph-fpjx-jg34"}],"prev":{"headline":"Social Web Suite \u003c= 4.1.12 - Unauthenticated Arbitrary Plugin Settings Update","id":"CVE-2026-88931"},"products":["multer"],"published":"2026-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["multer"]},"summary":"Remote attackers can exhaust disk space by repeatedly aborting uploads, causing denial of service in applications using this Node.js library.","url":"https://insights.sbomify.com/CVE-2026-88932/"}