# CVE-2026-88974: WPGraphQL: Contributor can publish and modify posts without the required capabilities via updatePost

> Contributors can bypass editorial approval to publish or modify posts due to missing capability checks in the WPGraphQL updatePost mutation.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-5mmc-8pc9-wggg

## What is CVE-2026-88974?

CVE-2026-88974 is a medium-severity missing authorization vulnerability in wp-graphql, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

WPGraphQL provides a GraphQL API for WordPress sites. Prior to 2.22.2, the updatePost mutation in src/Mutation/PostObjectUpdate.php checks only the collection-level edit_posts capability and the post author, but does not enforce the object-level edit_post capability or require publish_posts for public status transitions. An authenticated Contributor can therefore publish the Contributor's own draft without editorial approval or modify the Contributor's previously published post despite lacking edit_published_posts, while posts owned by other authors remain protected. This issue is fixed in version 2.22.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-88974?

2 open source packages ship an affected version, including wp-graphql/wp-graphql.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wp-graphql/wp-graphql` | Packagist | All versions | None |
| `wp-graphql/wp-graphql` | Packagist | All versions | None |

## How do I fix CVE-2026-88974?

No fix has been published for CVE-2026-88974 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-88974 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-88974 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88974 and fix it if it is affected.

What it is: CVE-2026-88974 is a medium-severity missing authorization vulnerability in wp-graphql, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-88974 exists.

Affected packages and fixed versions:
- wp-graphql/wp-graphql (Packagist): affected all versions; no fix listed
- wp-graphql/wp-graphql (Packagist): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88974/ (Markdown: https://insights.sbomify.com/CVE-2026-88974/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88974
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88974
- OSV: https://osv.dev/vulnerability/CVE-2026-88974

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88974/
Summaries are generated and may contain mistakes; the official description above is the record.
