CVE-2026-88975 Http4s: Ember HTTP/2 buffers a frame's declared payload before checking SETTINGS_MAX_FRAME_SIZE
An unauthenticated attacker can cause memory exhaustion and denial of service by sending oversized HTTP/2 frames that are buffered before validation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-88975?
CVE-2026-88975 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Http4s is a Scala interface for HTTP services. Prior to 0.23.37 and 1.0.0-M48, Ember’s HTTP/2 read loop parses a frame’s 24-bit declared length but waits to buffer the entire payload before comparing it with SETTINGS_MAX_FRAME_SIZE. An unauthenticated peer can declare a payload near 16 MiB on a connection where Ember advertised 16 KiB and either complete or slowly stream it, causing up to 1024-fold memory amplification per connection before processFrame can reject the frame. The shared H2Connection.readLoop affects withHttp2 servers and clients, while HTTP/2-disabled configurations are unaffected, and the patch rejects oversized frames before buffering their payloads. This issue is fixed in versions 0.23.37 and 1.0.0-M48.
Weakness: CWE-400
Which versions are affected by CVE-2026-88975?
10 open source packages ship an affected version, including org.http4s:http4s-ember-core_2.13, org.http4s:http4s-ember-core_2.12 and org.http4s:http4s-ember-core_3.
| Package | Affected | Fixed in |
|---|---|---|
org.http4s:http4s-ember-core_2.13 Maven | All versions | 0.23.37 |
org.http4s:http4s-ember-core_2.13 Maven | All versions | 0.23.37 |
org.http4s:http4s-ember-core_2.13 Maven | From 1.0.0-M1 | 1.0.0-M48 |
org.http4s:http4s-ember-core_2.13 Maven | From 1.0.0-M1 | 1.0.0-M48 |
org.http4s:http4s-ember-core_2.12 Maven | All versions | 0.23.37 |
org.http4s:http4s-ember-core_2.12 Maven | All versions | 0.23.37 |
4 more packages
org.http4s:http4s-ember-core_3 Maven | All versions | 0.23.37 |
org.http4s:http4s-ember-core_3 Maven | All versions | 0.23.37 |
org.http4s:http4s-ember-core_3 Maven | From 1.0.0-M1 | 1.0.0-M48 |
org.http4s:http4s-ember-core_3 Maven | From 1.0.0-M1 | 1.0.0-M48 |
How do I fix CVE-2026-88975?
Upgrade org.http4s:http4s-ember-core_2.13 to a fixed version for your release line: 0.23.37 or 1.0.0-M48.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-88975 being exploited?
There is no known exploitation of CVE-2026-88975 in the wild and no public exploit code.
Sources
Also known as GHSA-gq9p-f254-h286.