# CVE-2026-88975: Http4s: Ember HTTP/2 buffers a frame's declared payload before checking SETTINGS_MAX_FRAME_SIZE

> An unauthenticated attacker can cause memory exhaustion and denial of service by sending oversized HTTP/2 frames that are buffered before validation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-gq9p-f254-h286

## What is CVE-2026-88975?

CVE-2026-88975 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s is a Scala interface for HTTP services. Prior to 0.23.37 and 1.0.0-M48, Ember’s HTTP/2 read loop parses a frame’s 24-bit declared length but waits to buffer the entire payload before comparing it with SETTINGS_MAX_FRAME_SIZE. An unauthenticated peer can declare a payload near 16 MiB on a connection where Ember advertised 16 KiB and either complete or slowly stream it, causing up to 1024-fold memory amplification per connection before processFrame can reject the frame. The shared H2Connection.readLoop affects withHttp2 servers and clients, while HTTP/2-disabled configurations are unaffected, and the patch rejects oversized frames before buffering their payloads. This issue is fixed in versions 0.23.37 and 1.0.0-M48.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-88975?

10 open source packages ship an affected version, including org.http4s:http4s-ember-core_2.13, org.http4s:http4s-ember-core_2.12 and org.http4s:http4s-ember-core_3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4s:http4s-ember-core_2.13` | Maven | All versions | 0.23.37 |
| `org.http4s:http4s-ember-core_2.13` | Maven | All versions | 0.23.37 |
| `org.http4s:http4s-ember-core_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M48 |
| `org.http4s:http4s-ember-core_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M48 |
| `org.http4s:http4s-ember-core_2.12` | Maven | All versions | 0.23.37 |
| `org.http4s:http4s-ember-core_2.12` | Maven | All versions | 0.23.37 |
| `org.http4s:http4s-ember-core_3` | Maven | All versions | 0.23.37 |
| `org.http4s:http4s-ember-core_3` | Maven | All versions | 0.23.37 |
| `org.http4s:http4s-ember-core_3` | Maven | From 1.0.0-M1 | 1.0.0-M48 |
| `org.http4s:http4s-ember-core_3` | Maven | From 1.0.0-M1 | 1.0.0-M48 |

## How do I fix CVE-2026-88975?

Upgrade org.http4s:http4s-ember-core_2.13 to a fixed version for your release line: 0.23.37 or 1.0.0-M48.

## Is CVE-2026-88975 being exploited?

There is no known exploitation of CVE-2026-88975 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-88975 and fix it if it is affected.

What it is: CVE-2026-88975 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-88975 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4s:http4s-ember-core_2.13 (Maven): affected all versions; fixed in 0.23.37
- org.http4s:http4s-ember-core_2.13 (Maven): affected all versions; fixed in 0.23.37
- org.http4s:http4s-ember-core_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M48
- org.http4s:http4s-ember-core_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M48
- org.http4s:http4s-ember-core_2.12 (Maven): affected all versions; fixed in 0.23.37
- org.http4s:http4s-ember-core_2.12 (Maven): affected all versions; fixed in 0.23.37
- org.http4s:http4s-ember-core_3 (Maven): affected all versions; fixed in 0.23.37
- org.http4s:http4s-ember-core_3 (Maven): affected all versions; fixed in 0.23.37
- org.http4s:http4s-ember-core_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M48
- org.http4s:http4s-ember-core_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-88975/ (Markdown: https://insights.sbomify.com/CVE-2026-88975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-88975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-88975
- OSV: https://osv.dev/vulnerability/CVE-2026-88975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-88975/
Summaries are generated and may contain mistakes; the official description above is the record.
