# CVE-2026-89186: Information disclosure in mpp

> Attackers can access paid content via shared caches because the library's cache-control headers are overridden by the application, exposing sensitive data to unpaid users.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** EEF-CVE-2026-89186, GHSA-4h6w-pvrh-g28p, GHSA-82qh-vrvm-gqvc

## What is CVE-2026-89186?

CVE-2026-89186 is a medium-severity vulnerability in ZenHive mpp, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Use of Cache Containing Sensitive Information in ZenHive mpp allows a shared HTTP cache to store a paid response and serve it to clients that never paid.

MPP.Plug.verify_credential in lib/mpp/plug.ex sets payment-receipt and cache-control: private on the connection before the wrapped application runs, and registers no register_before_send/2 callback. Plug.Conn.put_resp_header/3 replaces an existing header, so a mounting application that sets its own cache-control on the paid resource (for example public, max-age=3600) silently overrides the private the library relies on, and a CDN or reverse proxy can then store the paid 200 together with its Payment-Receipt and serve both to unpaid clients. The library-level guarantee is therefore defeatable by the application it protects. For the same reason a downstream non-2xx response still carried Payment-Receipt, issuing a receipt for a response that delivered no resource.

This issue affects mpp: from 0.1.0 before 0.16.2.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2026-89186?

1 open source package ship an affected version, including mpp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mpp` | Hex | From 0.1.0 | 0.16.2 |

## How do I fix CVE-2026-89186?

Upgrade mpp to 0.16.2 or later.

## Is CVE-2026-89186 being exploited?

There is no known exploitation of CVE-2026-89186 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-89186 and fix it if it is affected.

What it is: CVE-2026-89186 is a medium-severity vulnerability in ZenHive mpp, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-89186 in the wild and no public exploit code.

Affected packages and fixed versions:
- mpp (Hex): affected from 0.1.0; fixed in 0.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-89186/ (Markdown: https://insights.sbomify.com/CVE-2026-89186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-89186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-89186
- OSV: https://osv.dev/vulnerability/CVE-2026-89186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-89186/
Summaries are generated and may contain mistakes; the official description above is the record.
