# CVE-2026-89259: Hugo before v0.165.0 Insufficient Permission Restriction via TailwindCSS

> Hugo allows TailwindCSS to bypass permission restrictions, enabling file read/write outside the project directory during builds.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2026
- **Updated:** 11 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-89259, GHSA-c34r-xm66-hh3p, GHSA-vrm6-x8vp-mv2r, MINI-4vfv-53c2-m43r, MINI-8r64-cmrq-49g2, UBUNTU-CVE-2026-89259

## What is CVE-2026-89259?

CVE-2026-89259 is a critical path traversal vulnerability in gohugoio hugo, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hugo is a static site generator. From v0.161.0, Hugo executes Node tools under Node's permission model, but TailwindCSS — included in the default security.exec.allow list — requires a highly permissive configuration (--allow-addons, --allow-child-process, --allow-worker). As a result, the restrictions intended by the fix for GHSA-x597-9fr4-5857 could still be bypassed, allowing a Node tool invoked during a build to read and write files outside the project's working directory. Affected versions are those after v0.43; the issue was fixed in v0.165.0 by removing tailwindcss from the default security.exec.allow list. Users who do not use TailwindCSS, or who only build trusted sites, are not affected. As a workaround, users can define a restrictive security.exec.allow list in hugo.toml.

Weakness: CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2026-89259?


## How do I fix CVE-2026-89259?

Upgrade to a fixed version.

## Is CVE-2026-89259 being exploited?

There is no known exploitation of CVE-2026-89259 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-89259 and fix it if it is affected.

What it is: CVE-2026-89259 is a critical path traversal vulnerability in gohugoio hugo, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-89259 in the wild and no public exploit code.

Affected product: gohugoio hugo. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-89259/ (Markdown: https://insights.sbomify.com/CVE-2026-89259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-89259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-89259
- OSV: https://osv.dev/vulnerability/CVE-2026-89259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-89259/
Summaries are generated and may contain mistakes; the official description above is the record.
