# CVE-2026-89322: Vault ACL Policy Evaluation May Allow Bypass of Deny Restrictions

> Authenticated users can bypass deny restrictions in Vault ACL policies due to inconsistent name evaluation, leading to privilege escalation.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** BIT-vault-2026-89322, GHSA-j78r-9xrv-vxf6, MINI-4mjc-cpf6-hm48

## What is CVE-2026-89322?

CVE-2026-89322 is a high-severity authentication bypass vulnerability in HashiCorp Vault, published on 7 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Vault and Vault Enterprise did not consistently evaluate ACL policies against the canonical form of resource and policy names. This may allow an authenticated user with delegated permissions to bypass an explicit deny restriction and access a protected resource or assign a denied policy, potentially leading to privilege escalation. This vulnerability (CVE-2026-89322) is fixed in Vault Community Edition 2.1.2, and Vault Enterprise 2.1.2, 1.21.12, 1.20.17, and 1.19.23.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-89322?

1 open source package ship an affected version, including vault.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vault` | Bitnami | From 0.0.1 | 2.1.2 |

## How do I fix CVE-2026-89322?

Upgrade vault to 2.1.2 or later.

## Is CVE-2026-89322 being exploited?

There is no known exploitation of CVE-2026-89322 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-89322 and fix it if it is affected.

What it is: CVE-2026-89322 is a high-severity authentication bypass vulnerability in HashiCorp Vault, published on 7 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-89322 in the wild and no public exploit code.

Affected packages and fixed versions:
- vault (Bitnami): affected from 0.0.1; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-89322/ (Markdown: https://insights.sbomify.com/CVE-2026-89322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-89322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-89322
- OSV: https://osv.dev/vulnerability/CVE-2026-89322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-89322/
Summaries are generated and may contain mistakes; the official description above is the record.
