# CVE-2026-89420: Session voucher adding no new funds is accepted without a charge in mpp, serving paid resources for free

> Attackers can access paid resources for free by replaying session vouchers, bypassing payment validation in the ZenHive mpp library.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** EEF-CVE-2026-89420, GHSA-8c63-r789-xrrf, GHSA-96m7-5wfv-978m

## What is CVE-2026-89420?

CVE-2026-89420 is a high-severity vulnerability in ZenHive mpp, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Validation of Specified Quantity in Input in ZenHive mpp allows a client holding an open payment channel to obtain paid resources without being charged.

MPP.Session.Actions.accept_voucher/3 in lib/mpp/session/actions.ex treats a voucher whose cumulativeAmount equals the channel's already-accepted cumulative amount as an idempotent success, returning the channel unchanged without calling maybe_spend/2. The credential verifies, the protected resource is served, and spent and units stay where they were. Because the server issues a fresh challenge per request and the credential replay store keys on challenge id and payload, the same signed voucher can be re-presented under every new challenge, so one paid voucher yields an unbounded number of paid units. The path is reachable from any method built on MPP.Session.Method through the Plug, MCP, JSON-RPC and WebSocket transports.

This issue affects mpp: from 0.14.0 before 0.16.2.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-89420?

1 open source package ship an affected version, including mpp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mpp` | Hex | From 0.14.0 | 0.16.2 |

## How do I fix CVE-2026-89420?

Upgrade mpp to 0.16.2 or later.

## Is CVE-2026-89420 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-89420 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-89420 and fix it if it is affected.

What it is: CVE-2026-89420 is a high-severity vulnerability in ZenHive mpp, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-89420 exists.

Affected packages and fixed versions:
- mpp (Hex): affected from 0.14.0; fixed in 0.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-89420/ (Markdown: https://insights.sbomify.com/CVE-2026-89420/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-89420
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-89420
- OSV: https://osv.dev/vulnerability/CVE-2026-89420

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-89420/
Summaries are generated and may contain mistakes; the official description above is the record.
