CVE-2026-90439 NGINX ngx_http_v3_module vulnerability
Remote attackers can cause denial of service or limited data corruption in NGINX via heap buffer overflow during TLS handshakes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-90439?
CVE-2026-90439 is a medium-severity memory corruption vulnerability in F5 NGINX Open Source, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_v3_module module. When using HTTP/3 with OpenSSL versions <= OpenSSL 3.5.0 under certain configurations, a limited heap buffer overflow could happen while processing a TLS handshake. This can happen in a non-deterministic manner that is beyond the attacker's control. This may cause a heap buffer overflow in the NGINX worker process leading to a restart and/or limited data corruption.
Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system or limited data corruption. There is no control plane exposure; this is a data plane issue only.
Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Weakness: CWE-122
Which versions are affected by CVE-2026-90439?
2 open source packages ship an affected version, including nginx and nginx-gateway.
| Package | Affected | Fixed in |
|---|---|---|
nginx Bitnami | From 1.29.2 | 1.30.0, 1.30.5, 1.31.6 |
nginx-gateway Bitnami | From 1.29.2 | 1.30.0, 1.30.5, 1.31.6 |
Linux distribution packages (13)
nginx Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-all-modules Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-core Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-filesystem Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-mod-devel Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-mod-http-geoip Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-mod-http-image-filter Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-mod-http-perl Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-mod-http-xslt-filter Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-mod-mail Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-mod-stream Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx-mod-stream-geoip Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
nginx openSUSE:Tumbleweed | All versions | 1.31.6-1.1 |
How do I fix CVE-2026-90439?
Upgrade nginx to a fixed version for your release line: 1.30.0, 1.30.5 or 1.31.6.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-90439 being exploited?
There is no known exploitation of CVE-2026-90439 in the wild and no public exploit code.
Sources
Also known as ALPINE-CVE-2026-90439, BELL-CVE-2026-90439, BIT-nginx-2026-90439, BIT-nginx-gateway-2026-90439, DEBIAN-CVE-2026-90439, GHSA-fjgw-pmcm-g7j7 and 6 more.