# CVE-2026-90439: NGINX ngx_http_v3_module vulnerability

> Remote attackers can cause denial of service or limited data corruption in NGINX via heap buffer overflow during TLS handshakes.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** ALPINE-CVE-2026-90439, BELL-CVE-2026-90439, BIT-nginx-2026-90439, BIT-nginx-gateway-2026-90439, DEBIAN-CVE-2026-90439, GHSA-fjgw-pmcm-g7j7, MGASA-2026-0499, MINI-2j2q-8x3w-wmfq, MINI-r9cp-4jww-9w57, MINI-v8vw-fgfj-rchc, RHSA-2026:67977, openSUSE-SU-2026:11807-1

## What is CVE-2026-90439?

CVE-2026-90439 is a medium-severity memory corruption vulnerability in F5 NGINX Open Source, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_v3_module module. When using HTTP/3 with OpenSSL versions <= OpenSSL 3.5.0 under certain configurations, a limited heap buffer overflow could happen while processing a TLS handshake. This can happen in a non-deterministic manner that is beyond the attacker's control. This may cause a heap buffer overflow in the NGINX worker process leading to a restart and/or limited data corruption.

Impact:
This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system or limited data corruption. There is no control plane exposure; this is a data plane issue only.

Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-90439?

2 open source packages ship an affected version, including nginx and nginx-gateway.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx` | Bitnami | From 1.29.2 | 1.30.0, 1.30.5, 1.31.6 |
| `nginx-gateway` | Bitnami | From 1.29.2 | 1.30.0, 1.30.5, 1.31.6 |
| `nginx` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-all-modules` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-core` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-filesystem` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-mod-devel` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-mod-http-geoip` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-mod-http-image-filter` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-mod-http-perl` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-mod-http-xslt-filter` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-mod-mail` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-mod-stream` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx-mod-stream-geoip` | Red Hat:hummingbird:1 | All versions | 0:1.30.5-4.hum1 |
| `nginx` | openSUSE:Tumbleweed | All versions | 1.31.6-1.1 |

## How do I fix CVE-2026-90439?

Upgrade nginx to a fixed version for your release line: 1.30.0, 1.30.5 or 1.31.6.

## Is CVE-2026-90439 being exploited?

There is no known exploitation of CVE-2026-90439 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-90439 and fix it if it is affected.

What it is: CVE-2026-90439 is a medium-severity memory corruption vulnerability in F5 NGINX Open Source, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-90439 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx (Bitnami): affected from 1.29.2; fixed in 1.30.0, 1.30.5, 1.31.6
- nginx-gateway (Bitnami): affected from 1.29.2; fixed in 1.30.0, 1.30.5, 1.31.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-90439/ (Markdown: https://insights.sbomify.com/CVE-2026-90439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-90439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-90439
- OSV: https://osv.dev/vulnerability/CVE-2026-90439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-90439/
Summaries are generated and may contain mistakes; the official description above is the record.
