CVE-2026-90534 Flowise before 3.1.4 Cross-Workspace Credential IDOR via node-load-method
Authenticated users can access credentials from other workspaces via an unsecured API endpoint, enabling unauthorized third-party provider calls and metadata disclosure.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-90534?
CVE-2026-90534 is a medium-severity missing authorization vulnerability in Flowiseai Flowise, published on 12 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Flowise is a low-code platform for building LLM applications. In versions up to and including 3.1.3, the POST /api/v1/node-load-method/:name endpoint is mounted without any route-level permission check and invokes component loadMethods with an attacker-controlled nodeName, loadMethod, inputs, and credential value. The selected credential is resolved by raw Credential.id via getCredentialData() and decrypted without verifying Credential.workspaceId against the caller's active or shared workspace, unlike other credential read paths which are workspace-scoped. As a result, an authenticated low-privilege user (or workspace API key) in one workspace can supply a credential ID owned by another workspace and cause Flowise to act as a confused deputy, performing third-party provider calls with the victim workspace's credential and returning provider metadata to the attacker. Statically identified affected load methods include Google Drive listFiles, Google Sheets listSpreadsheets, and AWS DynamoDB KV Storage listTables. The raw credential secret itself is not returned to the attacker. This issue is fixed in version 3.1.4.
Weakness: CWE-639
Which versions are affected by CVE-2026-90534?
It affects 1 product.
Products include Flowiseai Flowise.
How do I fix CVE-2026-90534?
No fix has been published for CVE-2026-90534 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-90534 being exploited?
There is no known exploitation of CVE-2026-90534 in the wild and no public exploit code.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-hqvm-7539-v83j, GHSA-wfvf-r9gr-6qfq.