# CVE-2026-90534: Flowise before 3.1.4 Cross-Workspace Credential IDOR via node-load-method

> Authenticated users can access credentials from other workspaces via an unsecured API endpoint, enabling unauthorized third-party provider calls and metadata disclosure.

- **Severity:** Medium 6.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-hqvm-7539-v83j, GHSA-wfvf-r9gr-6qfq

## What is CVE-2026-90534?

CVE-2026-90534 is a medium-severity missing authorization vulnerability in Flowiseai Flowise, published on 12 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise is a low-code platform for building LLM applications. In versions up to and including 3.1.3, the POST /api/v1/node-load-method/:name endpoint is mounted without any route-level permission check and invokes component loadMethods with an attacker-controlled nodeName, loadMethod, inputs, and credential value. The selected credential is resolved by raw Credential.id via getCredentialData() and decrypted without verifying Credential.workspaceId against the caller's active or shared workspace, unlike other credential read paths which are workspace-scoped. As a result, an authenticated low-privilege user (or workspace API key) in one workspace can supply a credential ID owned by another workspace and cause Flowise to act as a confused deputy, performing third-party provider calls with the victim workspace's credential and returning provider metadata to the attacker. Statically identified affected load methods include Google Drive listFiles, Google Sheets listSpreadsheets, and AWS DynamoDB KV Storage listTables. The raw credential secret itself is not returned to the attacker. This issue is fixed in version 3.1.4.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-90534?

It affects 1 product.


Products: Flowiseai Flowise.

## How do I fix CVE-2026-90534?

No fix has been published for CVE-2026-90534 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-90534 being exploited?

There is no known exploitation of CVE-2026-90534 in the wild and no public exploit code.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-90534 and fix it if it is affected.

What it is: CVE-2026-90534 is a medium-severity missing authorization vulnerability in Flowiseai Flowise, published on 12 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-90534 in the wild and no public exploit code.

Affected product: Flowiseai Flowise. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-90534/ (Markdown: https://insights.sbomify.com/CVE-2026-90534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-90534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-90534
- OSV: https://osv.dev/vulnerability/CVE-2026-90534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-90534/
Summaries are generated and may contain mistakes; the official description above is the record.
