# CVE-2026-90553: vLLM before 0.28.0 Remote Code Execution via LlavaOnevision2 processor

> Attackers can execute arbitrary code by crafting malicious models that bypass trust_remote_code restrictions in the vLLM LlavaOnevision2 processor.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-3c86-2m5g-59q7, GHSA-rp86-qf3f-pqfc, MINI-gxwf-x3hw-hm8w, MINI-v9m2-x2p6-6h9w, MINI-wh57-mq3m-cw5f, PYSEC-2026-3985

## What is CVE-2026-90553?

CVE-2026-90553 is a high-severity code injection vulnerability in Vllm Vllm, published on 12 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

vLLM before 0.28.0 contains a remote code execution vulnerability in the LlavaOnevision2 processor loader that ignores the trust_remote_code parameter when loading remote processor classes. Attackers can craft a malicious model with arbitrary code in processing_llava_onevision2.py that executes with vLLM process authority even when trust_remote_code is set to False.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-90553?

1 open source package ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.28.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-90553?

Upgrade vllm to 0.28.0 or later.

## Is CVE-2026-90553 being exploited?

There is no known exploitation of CVE-2026-90553 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-90553 and fix it if it is affected.

What it is: CVE-2026-90553 is a high-severity code injection vulnerability in Vllm Vllm, published on 12 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-90553 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.28.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-90553/ (Markdown: https://insights.sbomify.com/CVE-2026-90553/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-90553
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-90553
- OSV: https://osv.dev/vulnerability/CVE-2026-90553

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-90553/
Summaries are generated and may contain mistakes; the official description above is the record.
