# CVE-2026-90554: vLLM before 0.28.0 Denial of Service via audio extraction

> Attackers can cause denial of service by sending compressed video inputs to vLLM servers configured for audio extraction, forcing excessive memory allocation.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-936p-m5pv-vvjf, GHSA-m39m-2pqx-3vm2, MINI-96jv-wj5w-r4mr, MINI-pgrg-j7m3-7mrr, MINI-vmwx-cvrr-v6cv

## What is CVE-2026-90554?

CVE-2026-90554 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 12 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

vLLM versions >=0.10.2 and <0.28.0 do not apply any audio decode-size or duration limit when extracting audio from video input for NanoNemotronVL models. In nano_nemotron_vl.py, _extract_audio_from_videos calls load_audio_pyav(BytesIO(video_bytes)) without the max_duration_s or max_decode_bytes parameters, so neither VLLM_MAX_AUDIO_DECODE_DURATION_S nor VLLM_MAX_AUDIO_DECODE_BYTES is enforced (unlike the direct audio upload path in AudioMediaIO). When a NanoNemotronVL model is served with use_audio_in_video=True, an attacker who supplies a small, highly compressed video as multimodal input can force the server to allocate gigabytes of memory during audio decoding, resulting in a denial of service. Fixed in vLLM 0.28.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-90554?

It affects 1 product.


Products: Vllm Vllm.

## How do I fix CVE-2026-90554?

Upgrade to a fixed version.

## Is CVE-2026-90554 being exploited?

There is no known exploitation of CVE-2026-90554 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-90554 and fix it if it is affected.

What it is: CVE-2026-90554 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 12 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-90554 in the wild and no public exploit code.

Affected product: Vllm Vllm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-90554/ (Markdown: https://insights.sbomify.com/CVE-2026-90554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-90554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-90554
- OSV: https://osv.dev/vulnerability/CVE-2026-90554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-90554/
Summaries are generated and may contain mistakes; the official description above is the record.
