CVE-2026-90711 proxy-addr vulnerable to IP spoofing via IPv4-mapped IPv6 trust subnet
Attackers can spoof IP addresses by exploiting IPv4-mapped IPv6 trust subnet misconfigurations, bypassing IP-based access controls and rate limiting.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-90711?
CVE-2026-90711 is a critical vulnerability in proxy-addr, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
proxy-addr is a Node.js module that determines a request's client address behind trusted reverse proxies, and it backs Express req.ip and req.ips. In versions 1.1.0 through 2.0.7, a trust subnet written in IPv4-mapped IPv6 notation with an IPv4-sized prefix, such as ::ffff:10.0.0.0/8 instead of the correct ::ffff:10.0.0.0/104, is accepted without error but trusts every IPv4 address on the internet rather than the block it names. Because the socket peer then becomes trusted at hop 0, any unauthenticated client can supply an arbitrary X-Forwarded-For header and control the address the application reads, which defeats IP-based access control, rate limiting, geolocation, and audit logging. This is a fail-open regression introduced in version 1.1.0. The issue is fixed in proxy-addr 2.0.8, and users should upgrade to 2.0.8 or later. As a workaround, ensure any IPv4-mapped IPv6 trust subnet uses a prefix length of at least 97, or express the range in plain IPv4 notation.
Which versions are affected by CVE-2026-90711?
2 open source packages ship an affected version, including proxy-addr.
| Package | Affected | Fixed in |
|---|---|---|
proxy-addr npm | From 1.1.0 | 2.0.8 |
proxy-addr npm | From 1.1.0 | 2.0.8 |
How do I fix CVE-2026-90711?
Upgrade proxy-addr to 2.0.8 or later.
Is CVE-2026-90711 being exploited?
There is no known exploitation of CVE-2026-90711 in the wild and no public exploit code.
Sources
Also known as AZL-101775, CLEANSTART-2026-CT50806, DEBIAN-CVE-2026-90711, ECHO-0332-6c2f-c8ae, GHSA-jqcg-44mw-7w3h, MINI-2c8r-8gxx-5cpp and 24 more.